summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-10-30 07:20:41 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-10-30 07:20:41 +0000
commit5ddd2991137f49bf91ce06e9d9d190d01c0f3476 (patch)
tree7a2d4cd4d465ecf4ea3e10a00f8e0b1a3330b97a /dev-perl/PDL/PDL-2.3.2-r2.ebuild
parentMasking Speex cause someone has to (diff)
downloadgentoo-2-5ddd2991137f49bf91ce06e9d9d190d01c0f3476.tar.gz
gentoo-2-5ddd2991137f49bf91ce06e9d9d190d01c0f3476.tar.bz2
gentoo-2-5ddd2991137f49bf91ce06e9d9d190d01c0f3476.zip
revision bumps to force installations into correct locations after MakeMaker upgrade
Diffstat (limited to 'dev-perl/PDL/PDL-2.3.2-r2.ebuild')
-rw-r--r--dev-perl/PDL/PDL-2.3.2-r2.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-perl/PDL/PDL-2.3.2-r2.ebuild b/dev-perl/PDL/PDL-2.3.2-r2.ebuild
new file mode 100644
index 000000000000..d2f66ac2bc2d
--- /dev/null
+++ b/dev-perl/PDL/PDL-2.3.2-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/PDL-2.3.2-r2.ebuild,v 1.1 2002/10/30 07:20:40 seemant Exp $
+
+IUSE="opengl"
+
+inherit perl-module
+
+S=${WORKDIR}/${P}
+DESCRIPTION="PDL Perl Module"
+SRC_URI="http://cpan.valueclick.com/modules/by-module/PDL/${P}.tar.gz"
+HOMEPAGE="http://cpan.valueclick.com/modules/by-module/PDL/${P}.readme"
+
+SLOT="0"
+LICENSE="Artistic as-is"
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+
+DEPEND="${DEPEND}
+ >=sys-libs/ncurses-5.2
+ >=dev-perl/ExtUtils-F77-1.13
+ opengl? ( virtual/opengl virtual/glu )"
+
+mydoc="DEPNDENCIES DEVELOPMENT MANIFEST* COPYING Release_Notes TODO"
+
+src_unpack() {
+
+ unpack ${A}
+
+ #open gl does not work at the moment
+ if [ "`use opengl`" ]
+ then
+ echo "OpenGL support is current disabled due to build issues"
+ sed -e "s:WITH_3D => undef:WITH_3D => 0:" \
+ ${FILESDIR}/perldl.conf > ${S}/perldl.conf
+ else
+ sed -e "s:WITH_3D => undef:WITH_3D => 0:" \
+ ${FILESDIR}/perldl.conf > ${S}/perldl.conf
+ fi
+}
+
+src_install () {
+
+ perl-module_src_install
+
+ mv ${D}/usr/lib/perl5/site_perl/5.6.0/${CHOST%%-*}-linux/PDL/HtmlDocs \
+ ${D}/usr/doc/${P}/html
+
+ mydir=${D}/usr/doc/${P}/html/PDL
+
+ for i in ${mydir}/* ${mydir}/IO/* ${mydir}/Fit/* ${mydir}/Pod/* ${mydir}/Graphics/*
+ do
+ dosed ${i/${D}}
+ done
+
+ dosed /usr/lib/perl5/site_perl/5.6.0/${CHOST%%-*}-linux/PDL/pdldoc.db
+}