summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2012-10-07 15:51:34 +0000
committerTorsten Veller <tove@gentoo.org>2012-10-07 15:51:34 +0000
commitdefecc32577a2391fdce400230b3c837da519c72 (patch)
tree03cd8cae1f78692b54850a5d7002eade7cd92d03 /dev-perl/HTML-Mason
parentDrop alpha/sparc keywords (diff)
downloadgentoo-2-defecc32577a2391fdce400230b3c837da519c72.tar.gz
gentoo-2-defecc32577a2391fdce400230b3c837da519c72.tar.bz2
gentoo-2-defecc32577a2391fdce400230b3c837da519c72.zip
[bump] dev-perl/HTML-Mason-1.500.0
(Portage version: 2.2.0_alpha135/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/HTML-Mason')
-rw-r--r--dev-perl/HTML-Mason/ChangeLog8
-rw-r--r--dev-perl/HTML-Mason/HTML-Mason-1.500.0.ebuild63
-rw-r--r--dev-perl/HTML-Mason/metadata.xml3
3 files changed, 70 insertions, 4 deletions
diff --git a/dev-perl/HTML-Mason/ChangeLog b/dev-perl/HTML-Mason/ChangeLog
index d4258b009c96..24976a95bbe6 100644
--- a/dev-perl/HTML-Mason/ChangeLog
+++ b/dev-perl/HTML-Mason/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/HTML-Mason
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/ChangeLog,v 1.104 2012/06/24 12:59:37 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/ChangeLog,v 1.105 2012/10/07 15:51:34 tove Exp $
+
+*HTML-Mason-1.500.0 (07 Oct 2012)
+
+ 07 Oct 2012; Torsten Veller <tove@gentoo.org> +HTML-Mason-1.500.0.ebuild,
+ metadata.xml:
+ Version bump
24 Jun 2012; Torsten Veller <tove@gentoo.org> metadata.xml:
Update CPAN upstream info
diff --git a/dev-perl/HTML-Mason/HTML-Mason-1.500.0.ebuild b/dev-perl/HTML-Mason/HTML-Mason-1.500.0.ebuild
new file mode 100644
index 000000000000..54c31de21c31
--- /dev/null
+++ b/dev-perl/HTML-Mason/HTML-Mason-1.500.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/HTML-Mason/HTML-Mason-1.500.0.ebuild,v 1.1 2012/10/07 15:51:34 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=JSWARTZ
+MODULE_VERSION=1.50
+inherit depend.apache perl-module
+
+DESCRIPTION="A HTML development and delivery Perl Module"
+HOMEPAGE="http://www.masonhq.com/ ${HOMEPAGE}"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="modperl doc test"
+
+RDEPEND="!modperl? ( virtual/perl-CGI )
+ modperl? (
+ www-apache/libapreq2
+ >=www-apache/mod_perl-2
+ )
+ >=dev-perl/Params-Validate-0.7
+ >=dev-perl/Class-Container-0.08
+ >=dev-perl/Exception-Class-1.15
+ dev-perl/HTML-Parser
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-File-Spec
+ >=dev-perl/Cache-Cache-1.01
+ dev-perl/Log-Any"
+
+DEPEND="${RDEPEND}
+ virtual/perl-Module-Build
+ test? ( dev-perl/Test-Deep )"
+
+want_apache2 modperl
+
+SRC_TEST="do"
+mydoc="CREDITS UPGRADE"
+myconf="--noprompts"
+
+pkg_setup() {
+ depend.apache_pkg_setup modperl
+ perl-module_pkg_setup
+}
+
+src_prepare() {
+ # Note about new modperl use flag
+ if use !modperl ; then
+ ewarn "HTML-Mason will only install with modperl support"
+ ewarn "if the use flag modperl is enabled."
+ fi
+ # rendhalver - needed to set an env var for the build script so it finds our apache.
+ export APACHE="${APACHE_BIN}"
+ perl-module_src_prepare
+}
+
+src_install () {
+ perl-module_src_install
+ mv "${ED}"/usr/bin/convert* "${ED}"/usr/share/doc/${PF} || die
+ # rendhalver - the html docs have subdirs so this gets all of them
+ use doc && dohtml -r htdocs/*
+}
diff --git a/dev-perl/HTML-Mason/metadata.xml b/dev-perl/HTML-Mason/metadata.xml
index 5786ec5b395c..6f8534f86816 100644
--- a/dev-perl/HTML-Mason/metadata.xml
+++ b/dev-perl/HTML-Mason/metadata.xml
@@ -7,8 +7,6 @@
</use>
<upstream>
<remote-id type="cpan">HTML-Mason</remote-id>
- <remote-id type="cpan-module">Apache::Mason</remote-id>
- <remote-id type="cpan-module">Bundle::HTML::Mason</remote-id>
<remote-id type="cpan-module">HTML::Mason</remote-id>
<remote-id type="cpan-module">HTML::Mason::Apache::Request</remote-id>
<remote-id type="cpan-module">HTML::Mason::ApacheHandler</remote-id>
@@ -44,7 +42,6 @@
<remote-id type="cpan-module">HTML::Mason::Resolver</remote-id>
<remote-id type="cpan-module">HTML::Mason::Resolver::File</remote-id>
<remote-id type="cpan-module">HTML::Mason::Resolver::Null</remote-id>
- <remote-id type="cpan-module">HTML::Mason::Tests</remote-id>
<remote-id type="cpan-module">HTML::Mason::Tools</remote-id>
<remote-id type="cpan-module">HTML::Mason::Utils</remote-id>
<remote-id type="cpan-module">Tie::Handle::Mason</remote-id>