summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2008-09-10 17:12:12 +0000
committerTorsten Veller <tove@gentoo.org>2008-09-10 17:12:12 +0000
commite0843863e3af05347fe84fb89ec249643bf3f9a0 (patch)
treef3bccd3eb2c457bd4342fdcb92208247c13fda9e /dev-perl/GD
parentVersion bump (diff)
downloadgentoo-2-e0843863e3af05347fe84fb89ec249643bf3f9a0.tar.gz
gentoo-2-e0843863e3af05347fe84fb89ec249643bf3f9a0.tar.bz2
gentoo-2-e0843863e3af05347fe84fb89ec249643bf3f9a0.zip
Version bump
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-tuxonice i686)
Diffstat (limited to 'dev-perl/GD')
-rw-r--r--dev-perl/GD/ChangeLog7
-rw-r--r--dev-perl/GD/GD-2.41.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/dev-perl/GD/ChangeLog b/dev-perl/GD/ChangeLog
index bddef67c4233..7edfabce6ed2 100644
--- a/dev-perl/GD/ChangeLog
+++ b/dev-perl/GD/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/GD
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/GD/ChangeLog,v 1.78 2008/08/06 16:48:47 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/GD/ChangeLog,v 1.79 2008/09/10 17:12:11 tove Exp $
+
+*GD-2.41 (10 Sep 2008)
+
+ 10 Sep 2008; Torsten Veller <tove@gentoo.org> +GD-2.41.ebuild:
+ Version bump
06 Aug 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/dev-perl/GD/GD-2.41.ebuild b/dev-perl/GD/GD-2.41.ebuild
new file mode 100644
index 000000000000..67427072e820
--- /dev/null
+++ b/dev-perl/GD/GD-2.41.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/GD/GD-2.41.ebuild,v 1.1 2008/09/10 17:12:12 tove Exp $
+
+MODULE_AUTHOR=LDS
+inherit eutils perl-module
+
+DESCRIPTION="interface to Thomas Boutell's gd library"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="animgif gif jpeg png truetype xpm"
+
+DEPEND=">=media-libs/gd-2.0.33
+ png? ( media-libs/libpng sys-libs/zlib )
+ jpeg? ( media-libs/jpeg )
+ truetype? ( =media-libs/freetype-2* )
+ xpm? ( x11-libs/libXpm )
+ gif? ( media-libs/giflib )
+ dev-lang/perl"
+
+ SRC_TEST=do
+
+pkg_setup() {
+ local i_can_has_die=0
+
+ if use jpeg && ! built_with_use media-libs/gd jpeg; then
+ echo
+ eerror "If you want to compile dev-perl/GD with USE=jpeg, you must first"
+ eerror "compile media-libs/gd with USE=jpeg"
+ i_can_has_die=1
+ fi
+
+ if use truetype && ! built_with_use media-libs/gd truetype; then
+ echo
+ eerror "If you want to compile dev-perl/GD with USE=truetype, you must first"
+ eerror "compile media-libs/gd with USE=truetype"
+ i_can_has_die=1
+ fi
+
+ if use png && ! built_with_use media-libs/gd png; then
+ echo
+ eerror "If you want to compile dev-perl/GD with USE=png, you must first"
+ eerror "compile media-libs/gd with USE=png"
+ i_can_has_die=1
+ fi
+
+ if use xpm && ! built_with_use media-libs/gd xpm; then
+ echo
+ eerror "If you want to compile dev-perl/GD with USE=xpm, you must first"
+ eerror "compile media-libs/gd with USE=xpm"
+ i_can_has_die=1
+ fi
+
+ [[ ${i_can_has_die} -ne 0 ]] && die "Please fix the errors above before continuing"
+}
+
+src_compile() {
+ myconf=""
+ use gif && use animgif && myconf="${myconf},ANIMGIF"
+ use jpeg && myconf="${myconf},JPEG"
+ use truetype && myconf="${myconf},FREETYPE"
+ use png && myconf="${myconf},PNG"
+ use xpm && myconf="${myconf},XPM"
+ use gif && myconf="${myconf},GIF"
+ myconf="-options \"${myconf:1}\""
+ perl-module_src_compile
+}
+
+mydoc="GD.html"