summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-20 13:01:04 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-20 13:01:04 +0000
commit00b19703af9a25677dbeef689d272bec747beb78 (patch)
tree45a9ff63adab332b7090c55b4b1dce3526dc0c40 /dev-perl/File-RsyncP
parentRespect CC, #243962 (diff)
downloadgentoo-2-00b19703af9a25677dbeef689d272bec747beb78.tar.gz
gentoo-2-00b19703af9a25677dbeef689d272bec747beb78.tar.bz2
gentoo-2-00b19703af9a25677dbeef689d272bec747beb78.zip
Respect CC, #243960
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/File-RsyncP')
-rw-r--r--dev-perl/File-RsyncP/ChangeLog8
-rw-r--r--dev-perl/File-RsyncP/File-RsyncP-0.68.ebuild11
-rw-r--r--dev-perl/File-RsyncP/File-RsyncP-0.70.ebuild9
3 files changed, 21 insertions, 7 deletions
diff --git a/dev-perl/File-RsyncP/ChangeLog b/dev-perl/File-RsyncP/ChangeLog
index dcc8017bf9a2..54f11353625b 100644
--- a/dev-perl/File-RsyncP/ChangeLog
+++ b/dev-perl/File-RsyncP/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-perl/File-RsyncP
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/File-RsyncP/ChangeLog,v 1.24 2010/08/05 07:01:37 tove Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/File-RsyncP/ChangeLog,v 1.25 2011/04/20 13:01:04 jlec Exp $
+
+ 20 Apr 2011; Justin Lecher <jlec@gentoo.org> File-RsyncP-0.68.ebuild,
+ File-RsyncP-0.70.ebuild:
+ Respect CC, #243960
*File-RsyncP-0.70 (05 Aug 2010)
diff --git a/dev-perl/File-RsyncP/File-RsyncP-0.68.ebuild b/dev-perl/File-RsyncP/File-RsyncP-0.68.ebuild
index 6d1927a1efa3..dbf2206fc15b 100644
--- a/dev-perl/File-RsyncP/File-RsyncP-0.68.ebuild
+++ b/dev-perl/File-RsyncP/File-RsyncP-0.68.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/File-RsyncP/File-RsyncP-0.68.ebuild,v 1.10 2009/03/16 11:18:31 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/File-RsyncP/File-RsyncP-0.68.ebuild,v 1.11 2011/04/20 13:01:04 jlec Exp $
EAPI=2
MODULE_AUTHOR=CBARRATT
-inherit perl-module
+inherit perl-module toolchain-funcs
DESCRIPTION="An rsync perl module"
HOMEPAGE="http://perlrsync.sourceforge.net/"
@@ -18,3 +18,8 @@ IUSE=""
RDEPEND="net-misc/rsync"
MAKEOPTS="${MAKEOPTS} -j1"
+
+src_prepare() {
+ perl-module_src_prepare
+ tc-export CC
+}
diff --git a/dev-perl/File-RsyncP/File-RsyncP-0.70.ebuild b/dev-perl/File-RsyncP/File-RsyncP-0.70.ebuild
index be1d6ffd85fa..a9d64ace815c 100644
--- a/dev-perl/File-RsyncP/File-RsyncP-0.70.ebuild
+++ b/dev-perl/File-RsyncP/File-RsyncP-0.70.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/File-RsyncP/File-RsyncP-0.70.ebuild,v 1.1 2010/08/05 07:01:37 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/File-RsyncP/File-RsyncP-0.70.ebuild,v 1.2 2011/04/20 13:01:04 jlec Exp $
EAPI=3
@@ -18,3 +18,8 @@ IUSE=""
RDEPEND="net-misc/rsync"
MAKEOPTS+=" -j1"
+
+src_prepare() {
+ perl-module_src_prepare
+ tc-export CC
+}