summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-09-12 15:15:06 +0000
committerIan Delaney <idella4@gentoo.org>2013-09-12 15:15:06 +0000
commita6c919fb6616fcfe58bf7193b9e294e1052af228 (patch)
treef773c5cce1673de496f0191518c82d111a33ee30 /dev-perl/Exception-Base
parentStable for HPPA (bug #477178). (diff)
downloadgentoo-2-a6c919fb6616fcfe58bf7193b9e294e1052af228.tar.gz
gentoo-2-a6c919fb6616fcfe58bf7193b9e294e1052af228.tar.bz2
gentoo-2-a6c919fb6616fcfe58bf7193b9e294e1052af228.zip
revbump -> EAPI 5, remove old
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-perl/Exception-Base')
-rw-r--r--dev-perl/Exception-Base/ChangeLog8
-rw-r--r--dev-perl/Exception-Base/Exception-Base-0.240.100.ebuild22
-rw-r--r--dev-perl/Exception-Base/Exception-Base-0.250-r1.ebuild (renamed from dev-perl/Exception-Base/Exception-Base-0.250.ebuild)14
3 files changed, 18 insertions, 26 deletions
diff --git a/dev-perl/Exception-Base/ChangeLog b/dev-perl/Exception-Base/ChangeLog
index 188a09d69ffe..44bc0a7aa237 100644
--- a/dev-perl/Exception-Base/ChangeLog
+++ b/dev-perl/Exception-Base/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/Exception-Base
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Exception-Base/ChangeLog,v 1.11 2013/08/16 08:46:50 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Exception-Base/ChangeLog,v 1.12 2013/09/12 15:15:06 idella4 Exp $
+
+*Exception-Base-0.250-r1 (12 Sep 2013)
+
+ 12 Sep 2013; Ian Delaney <idella4@gentoo.org> +Exception-Base-0.250-r1.ebuild,
+ -Exception-Base-0.240.100.ebuild, -Exception-Base-0.250.ebuild:
+ revbump -> EAPI 5, remove old
*Exception-Base-0.250 (16 Aug 2013)
diff --git a/dev-perl/Exception-Base/Exception-Base-0.240.100.ebuild b/dev-perl/Exception-Base/Exception-Base-0.240.100.ebuild
deleted file mode 100644
index 8933d618afa8..000000000000
--- a/dev-perl/Exception-Base/Exception-Base-0.240.100.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Exception-Base/Exception-Base-0.240.100.ebuild,v 1.1 2011/01/14 12:08:13 tove Exp $
-
-EAPI=3
-
-MODULE_AUTHOR=DEXTER
-MODULE_VERSION=0.2401
-inherit perl-module
-
-DESCRIPTION="Error handling with exception class"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- virtual/perl-Module-Build
- test? ( >=dev-perl/Test-Unit-Lite-0.12 )"
-
-SRC_TEST=do
diff --git a/dev-perl/Exception-Base/Exception-Base-0.250.ebuild b/dev-perl/Exception-Base/Exception-Base-0.250-r1.ebuild
index 8237a02b2410..5aa7c3eb5577 100644
--- a/dev-perl/Exception-Base/Exception-Base-0.250.ebuild
+++ b/dev-perl/Exception-Base/Exception-Base-0.250-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Exception-Base/Exception-Base-0.250.ebuild,v 1.1 2013/08/16 08:46:50 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Exception-Base/Exception-Base-0.250-r1.ebuild,v 1.1 2013/09/12 15:15:06 idella4 Exp $
-EAPI=3
+EAPI=5
MODULE_AUTHOR=DEXTER
MODULE_VERSION=0.25
@@ -12,6 +12,7 @@ DESCRIPTION="Error handling with exception class"
SLOT="0"
KEYWORDS="~amd64 ~x86"
+# Package warrants IUSE examples
IUSE="test"
RDEPEND=""
@@ -19,4 +20,11 @@ DEPEND="${RDEPEND}
virtual/perl-Module-Build
test? ( >=dev-perl/Test-Unit-Lite-0.12 )"
-SRC_TEST=do
+SRC_TEST="do"
+
+src_install(){
+ perl-module_src_install
+ docompress -x usr/share/doc/${PF}/examples
+ insinto usr/share/doc/${PF}/
+ doins -r examples/
+}