summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2008-08-26 13:34:24 +0000
committerTorsten Veller <tove@gentoo.org>2008-08-26 13:34:24 +0000
commitb8027c98a9592b4d66244e83eb7c8422f052dd1f (patch)
tree5c9f5d34583cd09a6297a337ef7994679cecbb9e /dev-perl/Data-ShowTable
parentAdd init script and some other enhancements from Daniel Pielmeier in bug #217510 (diff)
downloadgentoo-2-b8027c98a9592b4d66244e83eb7c8422f052dd1f.tar.gz
gentoo-2-b8027c98a9592b4d66244e83eb7c8422f052dd1f.tar.bz2
gentoo-2-b8027c98a9592b4d66244e83eb7c8422f052dd1f.zip
Fix path to perl binary (#211058)
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-tuxonice i686)
Diffstat (limited to 'dev-perl/Data-ShowTable')
-rw-r--r--dev-perl/Data-ShowTable/ChangeLog8
-rw-r--r--dev-perl/Data-ShowTable/Data-ShowTable-3.3-r2.ebuild13
-rw-r--r--dev-perl/Data-ShowTable/files/3.3-perlpath.patch19
3 files changed, 30 insertions, 10 deletions
diff --git a/dev-perl/Data-ShowTable/ChangeLog b/dev-perl/Data-ShowTable/ChangeLog
index f707c8b1491f..fc5bc594b3b3 100644
--- a/dev-perl/Data-ShowTable/ChangeLog
+++ b/dev-perl/Data-ShowTable/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-perl/Data-ShowTable
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Data-ShowTable/ChangeLog,v 1.16 2007/01/15 17:17:56 mcummings Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Data-ShowTable/ChangeLog,v 1.17 2008/08/26 13:34:24 tove Exp $
+
+ 26 Aug 2008; Torsten Veller <tove@gentoo.org> +files/3.3-perlpath.patch,
+ Data-ShowTable-3.3-r2.ebuild:
+ Fix path to perl binary (#211058)
15 Jan 2007; Michael Cummings <mcummings@gentoo.org>
Data-ShowTable-3.3-r2.ebuild:
diff --git a/dev-perl/Data-ShowTable/Data-ShowTable-3.3-r2.ebuild b/dev-perl/Data-ShowTable/Data-ShowTable-3.3-r2.ebuild
index 0ca91c528364..000d79f21b5a 100644
--- a/dev-perl/Data-ShowTable/Data-ShowTable-3.3-r2.ebuild
+++ b/dev-perl/Data-ShowTable/Data-ShowTable-3.3-r2.ebuild
@@ -1,24 +1,21 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Data-ShowTable/Data-ShowTable-3.3-r2.ebuild,v 1.13 2007/07/10 23:33:29 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Data-ShowTable/Data-ShowTable-3.3-r2.ebuild,v 1.14 2008/08/26 13:34:24 tove Exp $
+MODULE_AUTHOR=AKSTE
inherit perl-module
DESCRIPTION="routines to display tabular data in several formats"
-SRC_URI="mirror://cpan/authors/id/A/AK/AKSTE/${P}.tar.gz"
-HOMEPAGE="http://search.cpan.org/~akste/"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="alpha amd64 ia64 ppc sparc x86"
IUSE=""
-mydoc="Copyright GNU-LICENSE"
+DEPEND="dev-lang/perl"
+PATCHES="${FILESDIR}/${PV}-perlpath.patch"
src_install () {
-
perl-module_src_install
dohtml *.html
}
-
-DEPEND="dev-lang/perl"
diff --git a/dev-perl/Data-ShowTable/files/3.3-perlpath.patch b/dev-perl/Data-ShowTable/files/3.3-perlpath.patch
new file mode 100644
index 000000000000..740f01486fe0
--- /dev/null
+++ b/dev-perl/Data-ShowTable/files/3.3-perlpath.patch
@@ -0,0 +1,19 @@
+--- libdata-showtable-perl-3.3.orig/showtable
++++ libdata-showtable-perl-3.3/showtable
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl5
++#!/usr/bin/perl
+ # showtable - read data and show it
+ #
+ # Copyright (C) 1996,1997 Alan K. Stebbens <aks@sgi.com>
+--- libdata-showtable-perl-3.3.orig/ShowTable.pm
++++ libdata-showtable-perl-3.3/ShowTable.pm
+@@ -721,7 +721,7 @@
+
+ S< >B<ShowHTMLTable> I<\@titles>, I<\@types>, I<\@widths>, I<\&row_sub>
+ [, I<\&fmt_sub> [, I<$max_width> [, I<\%URL_Keys> [, I<$no_escape>
+-[, I<\@title_formats [, I<\@data_formats [, I<$table_attrs> ] ] ] ] ] ] ];
++[, I<\@title_formats> [, I<\@data_formats> [, I<$table_attrs> ] ] ] ] ] ] ];
+
+ The B<ShowHTMLTable> displays one or more rows of columns of data using
+ the HTML C<\<TABLE\>> feature. In addition to the usual parameter arguments