summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Hartmann <ian@gentoo.org>2006-06-07 06:05:11 +0000
committerChristian Hartmann <ian@gentoo.org>2006-06-07 06:05:11 +0000
commit81013e08b6464bc49420a2626b307b6d234ddc6a (patch)
tree2bbfb2a254895296fd8b74d7dbf39721e24f54ca /dev-perl/Curses/Curses-1.14.ebuild
parentVersion bump (diff)
downloadgentoo-2-81013e08b6464bc49420a2626b307b6d234ddc6a.tar.gz
gentoo-2-81013e08b6464bc49420a2626b307b6d234ddc6a.tar.bz2
gentoo-2-81013e08b6464bc49420a2626b307b6d234ddc6a.zip
Version bump and cleanup of obsolete versions and patches
(Portage version: 2.1_rc4-r3)
Diffstat (limited to 'dev-perl/Curses/Curses-1.14.ebuild')
-rw-r--r--dev-perl/Curses/Curses-1.14.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/Curses/Curses-1.14.ebuild b/dev-perl/Curses/Curses-1.14.ebuild
new file mode 100644
index 000000000000..ad003d1b77d2
--- /dev/null
+++ b/dev-perl/Curses/Curses-1.14.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Curses/Curses-1.14.ebuild,v 1.1 2006/06/07 06:05:11 ian Exp $
+
+inherit perl-module eutils
+
+DESCRIPTION="Curses interface modules for Perl"
+HOMEPAGE="http://search.cpan.org/~giraffed/${P}/"
+SRC_URI="mirror://cpan/authors/id/G/GI/GIRAFFED/${P}.tgz"
+
+SLOT="0"
+LICENSE="Artistic"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+SRC_TEST="do"
+
+DEPEND="${DEPEND}
+ >=sys-libs/ncurses-5"
+RDEPEND="${DEPEND}"
+
+myconf="${myconf} GEN PANELS MENUS"
+
+#This patch may or may not be backwards compatible with perl-5.6.1
+#Add gaurd as necessary...
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/Curses-1.08-p5.8-fixes.diff
+ cd ${S}
+ einfo "Copying hints/c-linux.ncurses.h to c-config.h"
+ cp ${S}/hints/c-linux.ncurses.h ${S}/c-config.h
+}