summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2004-04-20 10:11:56 +0000
committerMichael Cummings <mcummings@gentoo.org>2004-04-20 10:11:56 +0000
commit95cd9750df77a6dc7a7c3e5dbdb7b9cad0ac3153 (patch)
tree4492ea7dc3ae3ade63bf8dfb8f41ed3f351ae674 /dev-perl/AxKit
parentMarked stable on amd64 (Manifest recommit) (diff)
downloadgentoo-2-95cd9750df77a6dc7a7c3e5dbdb7b9cad0ac3153.tar.gz
gentoo-2-95cd9750df77a6dc7a7c3e5dbdb7b9cad0ac3153.tar.bz2
gentoo-2-95cd9750df77a6dc7a7c3e5dbdb7b9cad0ac3153.zip
bug 48374; thanks Mr.Bones!!!
Diffstat (limited to 'dev-perl/AxKit')
-rw-r--r--dev-perl/AxKit/AxKit-1.6.1.ebuild6
-rw-r--r--dev-perl/AxKit/AxKit-1.6.2.ebuild6
-rw-r--r--dev-perl/AxKit/ChangeLog7
3 files changed, 14 insertions, 5 deletions
diff --git a/dev-perl/AxKit/AxKit-1.6.1.ebuild b/dev-perl/AxKit/AxKit-1.6.1.ebuild
index a576fc1e54a5..ccffdceec159 100644
--- a/dev-perl/AxKit/AxKit-1.6.1.ebuild
+++ b/dev-perl/AxKit/AxKit-1.6.1.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/AxKit/AxKit-1.6.1.ebuild,v 1.10 2004/04/16 11:17:37 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/AxKit/AxKit-1.6.1.ebuild,v 1.11 2004/04/20 10:11:56 mcummings Exp $
inherit perl-module
-MY_PV=$(echo $PV | perl -pe 's/\.([^.]+)$/\1/')
+front=${PV%\.*}
+back=${PV##*\.}
+MY_PV=${PV:0:${#front}}${back}
S=${WORKDIR}/${PN}-${MY_PV}
DESCRIPTION="The Apache AxKit Perl Module"
SRC_URI="http://axkit.org/download/${P}.tar.gz"
diff --git a/dev-perl/AxKit/AxKit-1.6.2.ebuild b/dev-perl/AxKit/AxKit-1.6.2.ebuild
index 4538f918022b..f12a6569543b 100644
--- a/dev-perl/AxKit/AxKit-1.6.2.ebuild
+++ b/dev-perl/AxKit/AxKit-1.6.2.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/AxKit/AxKit-1.6.2.ebuild,v 1.4 2004/04/16 11:17:37 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/AxKit/AxKit-1.6.2.ebuild,v 1.5 2004/04/20 10:11:56 mcummings Exp $
inherit perl-module
-MY_PV=$(echo $PV | perl -pe 's/\.([^.]+)$/\1/')
+front=${PV%\.*}
+back=${PV##*\.}
+MY_PV=${PV:0:${#front}}${back}
S=${WORKDIR}/${PN}-${MY_PV}
DESCRIPTION="The Apache AxKit Perl Module"
SRC_URI="http://axkit.org/download/${P}.tar.gz"
diff --git a/dev-perl/AxKit/ChangeLog b/dev-perl/AxKit/ChangeLog
index 67ede395a6a0..6b31ee3b382b 100644
--- a/dev-perl/AxKit/ChangeLog
+++ b/dev-perl/AxKit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/AxKit
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/AxKit/ChangeLog,v 1.23 2004/04/16 11:17:37 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/AxKit/ChangeLog,v 1.24 2004/04/20 10:11:56 mcummings Exp $
+
+ 20 Apr 2004; Michael Cummings <mcummings@gentoo.org> AxKit-1.6.1.ebuild,
+ AxKit-1.6.2.ebuild:
+ Syntax fix to remove global scope. Thanks to Mr. Bones for the syntax
+ help. Closes bug 48374
16 Apr 2004; Michael Cummings <mcummings@gentoo.org> AxKit-1.5.2-r1.ebuild,
AxKit-1.6-r1.ebuild, AxKit-1.6-r2.ebuild, AxKit-1.6.1.ebuild,