summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-09-01 13:34:08 +0000
committerTorsten Veller <tove@gentoo.org>2011-09-01 13:34:08 +0000
commitd9953284c9ab54bda016e8a4c0135ccfde48b5be (patch)
tree6419950a985255a2b11916fd30e8a293277e1b92 /dev-perl/Apache-Test/Apache-Test-1.360.0.ebuild
parentChange version scheme (diff)
downloadgentoo-2-d9953284c9ab54bda016e8a4c0135ccfde48b5be.tar.gz
gentoo-2-d9953284c9ab54bda016e8a4c0135ccfde48b5be.tar.bz2
gentoo-2-d9953284c9ab54bda016e8a4c0135ccfde48b5be.zip
Change version scheme
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/Apache-Test/Apache-Test-1.360.0.ebuild')
-rw-r--r--dev-perl/Apache-Test/Apache-Test-1.360.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-perl/Apache-Test/Apache-Test-1.360.0.ebuild b/dev-perl/Apache-Test/Apache-Test-1.360.0.ebuild
new file mode 100644
index 000000000000..1322ca5b7da1
--- /dev/null
+++ b/dev-perl/Apache-Test/Apache-Test-1.360.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Apache-Test/Apache-Test-1.360.0.ebuild,v 1.1 2011/09/01 13:34:08 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=PHRED
+MODULE_VERSION=1.36
+inherit depend.apache perl-module
+
+DESCRIPTION="Test.pm wrapper with helpers for testing Apache"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# interactive, requires interaction with the live filesystem
+SRC_TEST="skip"
+
+need_apache
+
+pkg_setup() {
+ perl-module_pkg_setup
+}
+
+src_install() {
+ # This is to avoid conflicts with a deprecated Apache::Test stepping
+ # in and causing problems/install errors
+ if [ -f "${S}"/.mypacklist ];
+ then
+ rm -f "${S}"/.mypacklist
+ fi
+ perl-module_src_install
+}