summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-02-07 19:32:09 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-02-07 19:32:09 +0000
commitfe1e8a3ff2b3b03476d21aa5fb5fa57751ef4bb3 (patch)
tree257021f9ec066e29bc2b7cb44877e939341003c6 /dev-ml
parentversion bump, eapi 5, add subslots and := deps (diff)
downloadgentoo-2-fe1e8a3ff2b3b03476d21aa5fb5fa57751ef4bb3.tar.gz
gentoo-2-fe1e8a3ff2b3b03476d21aa5fb5fa57751ef4bb3.tar.bz2
gentoo-2-fe1e8a3ff2b3b03476d21aa5fb5fa57751ef4bb3.zip
eapi 5, add subslot and := dep on ocaml
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/camlp5/ChangeLog7
-rw-r--r--dev-ml/camlp5/camlp5-6.07_p1.ebuild20
2 files changed, 15 insertions, 12 deletions
diff --git a/dev-ml/camlp5/ChangeLog b/dev-ml/camlp5/ChangeLog
index e22a4e0580f0..876b5bcf2741 100644
--- a/dev-ml/camlp5/ChangeLog
+++ b/dev-ml/camlp5/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/camlp5
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.71 2012/10/09 21:55:18 aballier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.72 2013/02/07 19:32:09 aballier Exp $
+
+ 07 Feb 2013; Alexis Ballier <aballier@gentoo.org> camlp5-6.07_p1.ebuild:
+ eapi 5, add subslot and := dep on ocaml
*camlp5-6.07_p1 (09 Oct 2012)
diff --git a/dev-ml/camlp5/camlp5-6.07_p1.ebuild b/dev-ml/camlp5/camlp5-6.07_p1.ebuild
index b005d1722c98..a3e64a0b8573 100644
--- a/dev-ml/camlp5/camlp5-6.07_p1.ebuild
+++ b/dev-ml/camlp5/camlp5-6.07_p1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/camlp5-6.07_p1.ebuild,v 1.1 2012/10/09 21:55:18 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/camlp5-6.07_p1.ebuild,v 1.2 2013/02/07 19:32:09 aballier Exp $
-EAPI="2"
+EAPI="5"
inherit multilib findlib eutils
@@ -12,11 +12,11 @@ HOMEPAGE="http://pauillac.inria.fr/~ddr/camlp5/"
SRC_URI="http://pauillac.inria.fr/~ddr/camlp5/distrib/src/${MY_P}.tgz"
LICENSE="BSD"
-SLOT="0"
+SLOT="0/${PV}"
KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
IUSE="doc +ocamlopt"
-DEPEND=">=dev-lang/ocaml-3.10[ocamlopt?]"
+DEPEND=">=dev-lang/ocaml-3.10:=[ocamlopt?]"
RDEPEND="${DEPEND}"
PATCHLEVEL=${PV#*_p}
@@ -48,18 +48,18 @@ src_configure() {
}
src_compile(){
- emake || die "emake failed"
+ emake
if use ocamlopt; then
- emake opt || die "Compiling native code programs failed"
- emake opt.opt || die "Compiling native code programs failed"
+ emake opt
+ emake opt.opt
fi
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install
# findlib support
insinto "$(ocamlfind printconf destdir)/${PN}"
- doins etc/META || die "failed to install META file for findlib support"
+ doins etc/META
use doc && dohtml -r doc/*