summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-11-01 14:12:08 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-11-01 14:12:08 +0000
commitef9f42087bba8b15a642e16f9ae14b7f33950b48 (patch)
tree71da23fefbf289658fd2e575ac0d3722ece3ab97 /dev-ml
parentKeyword ~ppc64 wrt #338835. (diff)
downloadgentoo-2-ef9f42087bba8b15a642e16f9ae14b7f33950b48.tar.gz
gentoo-2-ef9f42087bba8b15a642e16f9ae14b7f33950b48.tar.bz2
gentoo-2-ef9f42087bba8b15a642e16f9ae14b7f33950b48.zip
version bump
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/pcre-ocaml/ChangeLog8
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-6.1.1.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-ml/pcre-ocaml/ChangeLog b/dev-ml/pcre-ocaml/ChangeLog
index 41923a7dc620..65d9afbb2f3a 100644
--- a/dev-ml/pcre-ocaml/ChangeLog
+++ b/dev-ml/pcre-ocaml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/pcre-ocaml
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.31 2010/04/09 11:05:48 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.32 2010/11/01 14:12:08 aballier Exp $
+
+*pcre-ocaml-6.1.1 (01 Nov 2010)
+
+ 01 Nov 2010; Alexis Ballier <aballier@gentoo.org>
+ +pcre-ocaml-6.1.1.ebuild:
+ version bump
*pcre-ocaml-6.1.0 (09 Apr 2010)
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-6.1.1.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-6.1.1.ebuild
new file mode 100644
index 000000000000..09162adb96d8
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-6.1.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/pcre-ocaml-6.1.1.ebuild,v 1.1 2010/11/01 14:12:08 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
+HOMEPAGE="http://www.ocaml.info/home/ocaml_sources.html"
+SRC_URI="http://www.ocaml.info/ocaml_sources/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+
+RDEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
+ >=dev-libs/libpcre-4.5"
+DEPEND="${RDEPEND}"
+SLOT="0"
+IUSE="examples +ocamlopt"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-6.0.1-linkopts.patch"
+}
+
+src_compile() {
+ cd "${S}/lib"
+ emake byte-code-library || die "Failed to build byte code library"
+ if use ocamlopt; then
+ emake native-code-library || die "Failed to build native code library"
+ fi
+}
+
+src_install () {
+ export OCAMLFIND_INSTFLAGS="-optional"
+ findlib_src_install
+
+ # install documentation
+ dodoc README.txt Changelog
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}