summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-10-06 20:03:02 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-10-06 20:03:02 +0000
commiteaece0b7a00e6fa0c845229856d4db22bc0b9e4a (patch)
tree2da50cf11bf83537355ca127c06fbb06f8c794b4 /dev-ml
parentversion bump (diff)
downloadgentoo-2-eaece0b7a00e6fa0c845229856d4db22bc0b9e4a.tar.gz
gentoo-2-eaece0b7a00e6fa0c845229856d4db22bc0b9e4a.tar.bz2
gentoo-2-eaece0b7a00e6fa0c845229856d4db22bc0b9e4a.zip
version bump
(Portage version: 2.2.0_alpha62/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/sexplib/ChangeLog7
-rw-r--r--dev-ml/sexplib/sexplib-7.0.4.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-ml/sexplib/ChangeLog b/dev-ml/sexplib/ChangeLog
index 67cd36d309a2..1323048fb4ce 100644
--- a/dev-ml/sexplib/ChangeLog
+++ b/dev-ml/sexplib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/sexplib
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/sexplib/ChangeLog,v 1.11 2011/09/07 15:22:10 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/sexplib/ChangeLog,v 1.12 2011/10/06 20:03:02 aballier Exp $
+
+*sexplib-7.0.4 (06 Oct 2011)
+
+ 06 Oct 2011; Alexis Ballier <aballier@gentoo.org> +sexplib-7.0.4.ebuild:
+ version bump
*sexplib-7.0.3 (07 Sep 2011)
diff --git a/dev-ml/sexplib/sexplib-7.0.4.ebuild b/dev-ml/sexplib/sexplib-7.0.4.ebuild
new file mode 100644
index 000000000000..db948e7613e3
--- /dev/null
+++ b/dev-ml/sexplib/sexplib-7.0.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/sexplib/sexplib-7.0.4.ebuild,v 1.1 2011/10/06 20:03:02 aballier Exp $
+
+EAPI=3
+
+inherit findlib eutils multilib
+
+DESCRIPTION="Library for automated conversion of OCaml-values to and from S-expressions"
+HOMEPAGE="http://forge.ocamlcore.org/projects/sexplib/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/699/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc +ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.12[ocamlopt?]
+ >=dev-ml/type-conv-3.0.4"
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base dev-texlive/texlive-latexextra )"
+
+oasis_use_enable() {
+ echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
+}
+
+src_configure() {
+ ./configure --prefix usr \
+ --libdir /usr/$(get_libdir) \
+ --destdir "${D}" \
+ $(oasis_use_enable debug debug) \
+ $(oasis_use_enable ocamlopt is_native) \
+ || die
+}
+
+src_compile() {
+ emake || die
+ if use doc ; then
+ cd "${S}/doc"
+ pdflatex README || die
+ pdflatex README || die
+ fi
+}
+
+src_install() {
+ findlib_src_install
+
+ dodoc README.txt Changelog || die
+ if use doc; then
+ dodoc doc/README.pdf || die
+ fi
+}