summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-12-31 11:30:27 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-12-31 11:30:27 +0000
commitc9554fa9db528b44541ba12acd70af440e1768af (patch)
treed7b44241867e325f254808edab6f647f09053c6b /dev-ml
parentRemove ia64 support #345433 (diff)
downloadgentoo-2-c9554fa9db528b44541ba12acd70af440e1768af.tar.gz
gentoo-2-c9554fa9db528b44541ba12acd70af440e1768af.tar.bz2
gentoo-2-c9554fa9db528b44541ba12acd70af440e1768af.zip
version bump
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/pcre-ocaml/ChangeLog7
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-6.2.4.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-ml/pcre-ocaml/ChangeLog b/dev-ml/pcre-ocaml/ChangeLog
index cd0efc249cc9..9dd88316483f 100644
--- a/dev-ml/pcre-ocaml/ChangeLog
+++ b/dev-ml/pcre-ocaml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/pcre-ocaml
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.40 2011/12/07 13:20:42 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.41 2011/12/31 11:30:27 aballier Exp $
+
+*pcre-ocaml-6.2.4 (31 Dec 2011)
+
+ 31 Dec 2011; Alexis Ballier <aballier@gentoo.org> +pcre-ocaml-6.2.4.ebuild:
+ version bump
*pcre-ocaml-6.2.3 (07 Dec 2011)
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-6.2.4.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-6.2.4.ebuild
new file mode 100644
index 000000000000..48244b0f6cd4
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-6.2.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/pcre-ocaml-6.2.4.ebuild,v 1.1 2011/12/31 11:30:27 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
+HOMEPAGE="http://www.ocaml.info/home/ocaml_sources.html"
+SRC_URI="http://www.ocaml.info/ocaml_sources/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+
+RDEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
+ >=dev-libs/libpcre-4.5"
+DEPEND="${RDEPEND}"
+SLOT="0"
+IUSE="examples +ocamlopt"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-6.0.1-linkopts.patch"
+}
+
+src_compile() {
+ cd "${S}/lib"
+ emake byte-code-library || die "Failed to build byte code library"
+ if use ocamlopt; then
+ emake native-code-library || die "Failed to build native code library"
+ fi
+}
+
+src_install () {
+ export OCAMLFIND_INSTFLAGS="-optional"
+ findlib_src_install
+
+ # install documentation
+ dodoc README.txt Changelog
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}