summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-03-06 15:20:25 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-03-06 15:20:25 +0000
commitc8c6e6c5977fdcf64eaf9c1083cf1c49bafeb422 (patch)
treea8ca25e86b0f44dce48d609009e16c03ec74d79d /dev-ml
parenteapi5: define subslot, use slot deps and remove useless || die (diff)
downloadgentoo-2-c8c6e6c5977fdcf64eaf9c1083cf1c49bafeb422.tar.gz
gentoo-2-c8c6e6c5977fdcf64eaf9c1083cf1c49bafeb422.tar.bz2
gentoo-2-c8c6e6c5977fdcf64eaf9c1083cf1c49bafeb422.zip
eapi5: define subslot; use slot deps and remove useless || die
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/camomile/ChangeLog7
-rw-r--r--dev-ml/camomile/camomile-0.8.4.ebuild14
2 files changed, 12 insertions, 9 deletions
diff --git a/dev-ml/camomile/ChangeLog b/dev-ml/camomile/ChangeLog
index a9eb9378c5d6..3bd4f414892f 100644
--- a/dev-ml/camomile/ChangeLog
+++ b/dev-ml/camomile/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/camomile
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camomile/ChangeLog,v 1.35 2012/06/12 12:44:15 aballier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camomile/ChangeLog,v 1.36 2013/03/06 15:20:25 aballier Exp $
+
+ 06 Mar 2013; Alexis Ballier <aballier@gentoo.org> camomile-0.8.4.ebuild:
+ eapi5: define subslot; use slot deps and remove useless || die
12 Jun 2012; Alexis Ballier <aballier@gentoo.org> -camomile-0.8.3.ebuild:
remove old
diff --git a/dev-ml/camomile/camomile-0.8.4.ebuild b/dev-ml/camomile/camomile-0.8.4.ebuild
index 4078e391cc39..da17aeb9fd5e 100644
--- a/dev-ml/camomile/camomile-0.8.4.ebuild
+++ b/dev-ml/camomile/camomile-0.8.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camomile/camomile-0.8.4.ebuild,v 1.3 2012/05/29 19:38:32 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camomile/camomile-0.8.4.ebuild,v 1.4 2013/03/06 15:20:25 aballier Exp $
-EAPI="2"
+EAPI="5"
inherit findlib eutils
@@ -11,11 +11,11 @@ HOMEPAGE="http://github.com/yoriyuki/Camomile/wiki"
SRC_URI="http://github.com/downloads/yoriyuki/Camomile/${P}.tar.bz2"
LICENSE="LGPL-2"
-SLOT="0"
+SLOT="0/${PV}"
KEYWORDS="~amd64 ppc x86"
IUSE="debug +ocamlopt"
-RDEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]"
+RDEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]"
DEPEND="${RDEPEND}"
src_configure() {
@@ -23,9 +23,9 @@ src_configure() {
}
src_compile() {
- emake -j1 byte unidata unimaps charmap_data locale_data || die "failed to build"
+ emake -j1 byte unidata unimaps charmap_data locale_data
if use ocamlopt; then
- emake -j1 opt || die "failed to build native code"
+ emake -j1 opt
fi
}