summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-01-20 19:53:13 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-01-20 19:53:13 +0000
commitc3a3fd375ac49fd61401b3c4464d118a8f941b24 (patch)
treeafa6453c357148a81a92ca7b3b2d4a13292cb154 /dev-ml
parentremove old (diff)
downloadgentoo-2-c3a3fd375ac49fd61401b3c4464d118a8f941b24.tar.gz
gentoo-2-c3a3fd375ac49fd61401b3c4464d118a8f941b24.tar.bz2
gentoo-2-c3a3fd375ac49fd61401b3c4464d118a8f941b24.zip
version bump
(Portage version: 2.2.0_alpha18/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/fieldslib/ChangeLog9
-rw-r--r--dev-ml/fieldslib/fieldslib-0.1.1.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/dev-ml/fieldslib/ChangeLog b/dev-ml/fieldslib/ChangeLog
index acb870d1f529..98a725a6f8a6 100644
--- a/dev-ml/fieldslib/ChangeLog
+++ b/dev-ml/fieldslib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/fieldslib
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/fieldslib/ChangeLog,v 1.1 2009/10/27 12:08:13 aballier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/fieldslib/ChangeLog,v 1.2 2011/01/20 19:53:13 aballier Exp $
+
+*fieldslib-0.1.1 (20 Jan 2011)
+
+ 20 Jan 2011; Alexis Ballier <aballier@gentoo.org> +fieldslib-0.1.1.ebuild:
+ version bump
*fieldslib-0.1.0 (27 Oct 2009)
diff --git a/dev-ml/fieldslib/fieldslib-0.1.1.ebuild b/dev-ml/fieldslib/fieldslib-0.1.1.ebuild
new file mode 100644
index 000000000000..6b1883651acf
--- /dev/null
+++ b/dev-ml/fieldslib/fieldslib-0.1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/fieldslib/fieldslib-0.1.1.ebuild,v 1.1 2011/01/20 19:53:13 aballier Exp $
+
+EAPI="2"
+inherit findlib multilib
+
+DESCRIPTION="Folding over record fields"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://www.janestreet.com/ocaml/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt]
+ dev-ml/type-conv"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+oasis_use_enable() {
+ echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
+}
+
+src_configure() {
+ ./configure --prefix usr \
+ --libdir /usr/$(get_libdir) \
+ --destdir "${D}" \
+ $(oasis_use_enable debug debug) \
+ $(oasis_use_enable ocamlopt is_native) \
+ || die
+}
+
+src_install() {
+ findlib_src_install
+
+ # install documentation
+ dodoc README || die
+}