summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-01-20 19:59:19 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-01-20 19:59:19 +0000
commitb49040f198d0f75a88191c244309a337b415356d (patch)
tree6111250cba69d2bbb42ca18a63a63734add3efdb /dev-ml
parentocamlopt is now optional (diff)
downloadgentoo-2-b49040f198d0f75a88191c244309a337b415356d.tar.gz
gentoo-2-b49040f198d0f75a88191c244309a337b415356d.tar.bz2
gentoo-2-b49040f198d0f75a88191c244309a337b415356d.zip
version bump
(Portage version: 2.2.0_alpha18/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/pcre-ocaml/ChangeLog7
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-6.2.2.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-ml/pcre-ocaml/ChangeLog b/dev-ml/pcre-ocaml/ChangeLog
index dc4c48756a08..a97937fb92aa 100644
--- a/dev-ml/pcre-ocaml/ChangeLog
+++ b/dev-ml/pcre-ocaml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/pcre-ocaml
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.36 2011/01/20 15:54:56 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.37 2011/01/20 19:59:19 aballier Exp $
+
+*pcre-ocaml-6.2.2 (20 Jan 2011)
+
+ 20 Jan 2011; Alexis Ballier <aballier@gentoo.org> +pcre-ocaml-6.2.2.ebuild:
+ version bump
20 Jan 2011; Alexis Ballier <aballier@gentoo.org> -pcre-ocaml-6.0.1.ebuild,
-pcre-ocaml-6.1.0.ebuild:
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-6.2.2.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-6.2.2.ebuild
new file mode 100644
index 000000000000..08ed21e0086c
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-6.2.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/pcre-ocaml-6.2.2.ebuild,v 1.1 2011/01/20 19:59:19 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
+HOMEPAGE="http://www.ocaml.info/home/ocaml_sources.html"
+SRC_URI="http://www.ocaml.info/ocaml_sources/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+
+RDEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
+ >=dev-libs/libpcre-4.5"
+DEPEND="${RDEPEND}"
+SLOT="0"
+IUSE="examples +ocamlopt"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-6.0.1-linkopts.patch"
+}
+
+src_compile() {
+ cd "${S}/lib"
+ emake byte-code-library || die "Failed to build byte code library"
+ if use ocamlopt; then
+ emake native-code-library || die "Failed to build native code library"
+ fi
+}
+
+src_install () {
+ export OCAMLFIND_INSTFLAGS="-optional"
+ findlib_src_install
+
+ # install documentation
+ dodoc README.txt Changelog
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}