summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-03-10 10:33:58 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-03-10 10:33:58 +0000
commitac8bbb8c97d6d59ec83289330718a279172f43a9 (patch)
treed0676de8108b1d08a5007a546643d31c80fdd0b4 /dev-ml
parentremove old (diff)
downloadgentoo-2-ac8bbb8c97d6d59ec83289330718a279172f43a9.tar.gz
gentoo-2-ac8bbb8c97d6d59ec83289330718a279172f43a9.tar.bz2
gentoo-2-ac8bbb8c97d6d59ec83289330718a279172f43a9.zip
eapi5: define subslot and add missing dep on ocaml:=[ocamlopt]
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocurl/ChangeLog7
-rw-r--r--dev-ml/ocurl/ocurl-0.5.3.ebuild17
2 files changed, 14 insertions, 10 deletions
diff --git a/dev-ml/ocurl/ChangeLog b/dev-ml/ocurl/ChangeLog
index 69d8b33eca75..8b1c488051b9 100644
--- a/dev-ml/ocurl/ChangeLog
+++ b/dev-ml/ocurl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/ocurl
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocurl/ChangeLog,v 1.11 2011/12/18 19:54:08 phajdan.jr Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocurl/ChangeLog,v 1.12 2013/03/10 10:33:58 aballier Exp $
+
+ 10 Mar 2013; Alexis Ballier <aballier@gentoo.org> ocurl-0.5.3.ebuild:
+ eapi5: define subslot and add missing dep on ocaml:=[ocamlopt]
18 Dec 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> ocurl-0.5.3.ebuild:
x86 stable wrt bug #393761
diff --git a/dev-ml/ocurl/ocurl-0.5.3.ebuild b/dev-ml/ocurl/ocurl-0.5.3.ebuild
index 1b51b5d15da1..0a4d8937fa20 100644
--- a/dev-ml/ocurl/ocurl-0.5.3.ebuild
+++ b/dev-ml/ocurl/ocurl-0.5.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocurl/ocurl-0.5.3.ebuild,v 1.3 2011/12/18 19:54:08 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocurl/ocurl-0.5.3.ebuild,v 1.4 2013/03/10 10:33:58 aballier Exp $
-EAPI=2
+EAPI=5
inherit eutils findlib autotools
@@ -11,12 +11,13 @@ HOMEPAGE="http://sourceforge.net/projects/ocurl"
LICENSE="MIT"
SRC_URI="mirror://sourceforge/ocurl/${P}.tgz"
-SLOT="0"
+SLOT="0/${PV}"
IUSE="examples"
DEPEND=">=net-misc/curl-7.9.8
-dev-libs/openssl"
-RDEPEND="$DEPEND"
+ dev-libs/openssl
+ >=dev-lang/ocaml-3.12:=[ocamlopt]"
+RDEPEND="${DEPEND}"
KEYWORDS="amd64 ~ppc x86"
S=${WORKDIR}/${PN}
@@ -39,7 +40,7 @@ src_install()
{
findlib_src_install
if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
fi
}