summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-05-12 06:57:12 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-05-12 06:57:12 +0000
commitaa2393cfcf3aa4a9796df20c39e100aeb19eb134 (patch)
tree86ac75117e2e88364d5f5e8fe3edbbc9f5ac85da /dev-ml
parentremove old (diff)
downloadgentoo-2-aa2393cfcf3aa4a9796df20c39e100aeb19eb134.tar.gz
gentoo-2-aa2393cfcf3aa4a9796df20c39e100aeb19eb134.tar.bz2
gentoo-2-aa2393cfcf3aa4a9796df20c39e100aeb19eb134.zip
version bump
(Portage version: 2.1.5_rc10)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-sqlite3/ChangeLog8
-rw-r--r--dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.2.0.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/dev-ml/ocaml-sqlite3/ChangeLog b/dev-ml/ocaml-sqlite3/ChangeLog
index 29515858af5c..d63d6695cefd 100644
--- a/dev-ml/ocaml-sqlite3/ChangeLog
+++ b/dev-ml/ocaml-sqlite3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/ocaml-sqlite3
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ChangeLog,v 1.6 2008/04/13 19:23:28 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ChangeLog,v 1.7 2008/05/12 06:57:12 aballier Exp $
+
+*ocaml-sqlite3-1.2.0 (12 May 2008)
+
+ 12 May 2008; Alexis Ballier <aballier@gentoo.org>
+ +ocaml-sqlite3-1.2.0.ebuild:
+ version bump
13 Apr 2008; Alexis Ballier <aballier@gentoo.org>
-ocaml-sqlite3-0.23.0.ebuild:
diff --git a/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.2.0.ebuild b/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.2.0.ebuild
new file mode 100644
index 000000000000..c9a8add7c699
--- /dev/null
+++ b/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.2.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.2.0.ebuild,v 1.1 2008/05/12 06:57:12 aballier Exp $
+
+inherit findlib eutils
+
+EAPI="1"
+
+IUSE="doc +ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to SQLite databases."
+SRC_URI="http://ocaml.info/ocaml_sources/${P}.tar.bz2"
+HOMEPAGE="http://ocaml.info/home/ocaml_sources.html#ocaml-sqlite3"
+
+DEPEND=">=dev-lang/ocaml-3.09
+ >=dev-db/sqlite-3.3.3"
+
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+pkg_setup() {
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-0.22.0-destdir.patch"
+ epatch "${FILESDIR}/${PN}-0.23.0-noocamlopt.patch"
+}
+
+src_compile() {
+ econf
+ emake -j1 bytecode || die "make bytecode failed"
+ if use ocamlopt; then
+ emake -j1 opt || die "make opt failed"
+ fi
+ if use doc; then
+ emake -j1 docs || die "make doc failed"
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ export OCAMLPATH="${OCAMLFIND_DESTDIR}"
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc CHANGES README TODO
+ use doc && dohtml doc/*
+}