summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-10-16 14:35:08 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-10-16 14:35:08 +0000
commit9fbb2f5531bfbd209edaab3094ea93fd3f349b20 (patch)
treee7d5e926b2dab989ea4605ace221d890dfc42808 /dev-ml
parentAdded -ffixed-line-length-132 to FFLAGS to avoid gcc-4.1.2 errors due to line... (diff)
downloadgentoo-2-9fbb2f5531bfbd209edaab3094ea93fd3f349b20.tar.gz
gentoo-2-9fbb2f5531bfbd209edaab3094ea93fd3f349b20.tar.bz2
gentoo-2-9fbb2f5531bfbd209edaab3094ea93fd3f349b20.zip
version bump
(Portage version: 2.2_rc12/cvs/Linux 2.6.26.6 x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/camlp5/ChangeLog7
-rw-r--r--dev-ml/camlp5/camlp5-5.10.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-ml/camlp5/ChangeLog b/dev-ml/camlp5/ChangeLog
index cf9c9d5a9526..37ed9d7c1719 100644
--- a/dev-ml/camlp5/ChangeLog
+++ b/dev-ml/camlp5/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/camlp5
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.28 2008/09/25 12:09:13 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.29 2008/10/16 14:35:08 aballier Exp $
+
+*camlp5-5.10 (16 Oct 2008)
+
+ 16 Oct 2008; Alexis Ballier <aballier@gentoo.org> +camlp5-5.10.ebuild:
+ version bump
25 Sep 2008; Alexis Ballier <aballier@gentoo.org> camlp5-5.09.ebuild:
keyword ~x86-fbsd
diff --git a/dev-ml/camlp5/camlp5-5.10.ebuild b/dev-ml/camlp5/camlp5-5.10.ebuild
new file mode 100644
index 000000000000..dd1fba878abb
--- /dev/null
+++ b/dev-ml/camlp5/camlp5-5.10.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/camlp5-5.10.ebuild,v 1.1 2008/10/16 14:35:08 aballier Exp $
+
+EAPI="2"
+
+inherit multilib findlib eutils
+
+DESCRIPTION="A preprocessor-pretty-printer of ocaml"
+HOMEPAGE="http://pauillac.inria.fr/~ddr/camlp5/"
+SRC_URI="http://pauillac.inria.fr/~ddr/camlp5/distrib/src/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="doc +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.10[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ ./configure \
+ -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/$(get_libdir)/ocaml \
+ -mandir /usr/share/man || die "configure failed"
+}
+
+src_compile(){
+ emake -j1 || die "emake failed"
+ if use ocamlopt; then
+ emake -j1 opt || die "Compiling native code programs failed"
+ emake -j1 opt.opt || die "Compiling native code programs failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ # findlib support
+ insinto "$(ocamlfind printconf destdir)/${PN}"
+ doins etc/META || die "failed to install META file for findlib support"
+
+ use doc && dohtml -r doc/*
+
+ dodoc CHANGES DEVEL ICHANGES README UPGRADING MODE
+}