summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-11-02 14:56:17 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-11-02 14:56:17 +0000
commit9c18d039dd6a05c0b4cbb2f614c912054cb8508e (patch)
treec18da9be1ecaa5607f231dcbd741d216280a190d /dev-ml
parentkeyword ~x86-fbsd (diff)
downloadgentoo-2-9c18d039dd6a05c0b4cbb2f614c912054cb8508e.tar.gz
gentoo-2-9c18d039dd6a05c0b4cbb2f614c912054cb8508e.tar.bz2
gentoo-2-9c18d039dd6a05c0b4cbb2f614c912054cb8508e.zip
version bump
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-ssl/ChangeLog7
-rw-r--r--dev-ml/ocaml-ssl/ocaml-ssl-0.4.6.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-ml/ocaml-ssl/ChangeLog b/dev-ml/ocaml-ssl/ChangeLog
index 18cee894b43b..fdc6f50db324 100644
--- a/dev-ml/ocaml-ssl/ChangeLog
+++ b/dev-ml/ocaml-ssl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocaml-ssl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-ssl/ChangeLog,v 1.18 2011/04/19 18:37:01 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-ssl/ChangeLog,v 1.19 2011/11/02 14:56:17 aballier Exp $
+
+*ocaml-ssl-0.4.6 (02 Nov 2011)
+
+ 02 Nov 2011; Alexis Ballier <aballier@gentoo.org> +ocaml-ssl-0.4.6.ebuild:
+ version bump
*ocaml-ssl-0.4.5 (19 Apr 2011)
diff --git a/dev-ml/ocaml-ssl/ocaml-ssl-0.4.6.ebuild b/dev-ml/ocaml-ssl/ocaml-ssl-0.4.6.ebuild
new file mode 100644
index 000000000000..de6572e23d1c
--- /dev/null
+++ b/dev-ml/ocaml-ssl/ocaml-ssl-0.4.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-ssl/ocaml-ssl-0.4.6.ebuild,v 1.1 2011/11/02 14:56:17 aballier Exp $
+
+inherit findlib eutils
+
+IUSE="doc"
+
+DESCRIPTION="OCaml bindings for OpenSSL."
+SRC_URI="mirror://sourceforge/savonet/${P}.tar.gz"
+HOMEPAGE="http://savonet.sourceforge.net"
+
+DEPEND="dev-libs/openssl"
+
+RDEPEND="$DEPEND"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+src_compile() {
+ econf || die "configure failed"
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ findlib_src_preinst
+ emake install || die "make install failed"
+
+ if use doc; then
+ dohtml -r doc/html/*
+ fi
+ dodoc CHANGES README
+}