summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-06-22 12:22:36 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-06-22 12:22:36 +0000
commit9a017df6624f7002cc78192f9b917c7512e52342 (patch)
tree7f093231316a403a250565026abcfeac18fbcb8a /dev-ml
parentFix shebangs only with USE python (reported by angelos). (diff)
downloadgentoo-2-9a017df6624f7002cc78192f9b917c7512e52342.tar.gz
gentoo-2-9a017df6624f7002cc78192f9b917c7512e52342.tar.bz2
gentoo-2-9a017df6624f7002cc78192f9b917c7512e52342.zip
version bump
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/pxp/ChangeLog9
-rw-r--r--dev-ml/pxp/pxp-1.2.2.ebuild50
2 files changed, 57 insertions, 2 deletions
diff --git a/dev-ml/pxp/ChangeLog b/dev-ml/pxp/ChangeLog
index 9e5aba1f64bc..4c44f58f98bf 100644
--- a/dev-ml/pxp/ChangeLog
+++ b/dev-ml/pxp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/pxp
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pxp/ChangeLog,v 1.21 2009/11/25 17:03:32 aballier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pxp/ChangeLog,v 1.22 2011/06/22 12:22:36 aballier Exp $
+
+*pxp-1.2.2 (22 Jun 2011)
+
+ 22 Jun 2011; Alexis Ballier <aballier@gentoo.org> +pxp-1.2.2.ebuild:
+ version bump
25 Nov 2009; Alexis Ballier <aballier@gentoo.org> -pxp-1.1.6.ebuild:
remove old
diff --git a/dev-ml/pxp/pxp-1.2.2.ebuild b/dev-ml/pxp/pxp-1.2.2.ebuild
new file mode 100644
index 000000000000..e964aaeee9f6
--- /dev/null
+++ b/dev-ml/pxp/pxp-1.2.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pxp/pxp-1.2.2.ebuild,v 1.1 2011/06/22 12:22:36 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+MY_P=${P/_beta/test}
+
+DESCRIPTION="validating XML parser library for O'Caml"
+HOMEPAGE="http://projects.camlcity.org/projects/pxp.html"
+SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+SLOT="0"
+DEPEND=">=dev-ml/pcre-ocaml-4.31
+>=dev-ml/ulex-0.5
+>=dev-ml/ocamlnet-0.98
+>=dev-lang/ocaml-3.10.2[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+IUSE="examples +ocamlopt"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ #the included configure does not support many standard switches and is quite picky
+ ./configure || die "configure failed"
+}
+
+src_compile() {
+ emake -j1 all || die "make all failed"
+ if use ocamlopt; then
+ emake -j1 opt || die "make opt failed"
+ fi
+}
+
+src_install() {
+ findlib_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+
+ cd doc
+ dodoc ABOUT-FINDLIB DEV README SPEC design.txt
+}