summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-04-19 18:31:25 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-04-19 18:31:25 +0000
commit8ccf1afc0030e776c9a02f1fdbb998e9e3eafa89 (patch)
tree5f209b050fe7823056985753a0262dec60d05f4f /dev-ml
parentversion bump (diff)
downloadgentoo-2-8ccf1afc0030e776c9a02f1fdbb998e9e3eafa89.tar.gz
gentoo-2-8ccf1afc0030e776c9a02f1fdbb998e9e3eafa89.tar.bz2
gentoo-2-8ccf1afc0030e776c9a02f1fdbb998e9e3eafa89.zip
version bump
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/camlp5/ChangeLog7
-rw-r--r--dev-ml/camlp5/camlp5-6.02.2_p3.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/dev-ml/camlp5/ChangeLog b/dev-ml/camlp5/ChangeLog
index 7d2095d28bd3..928a95cb7935 100644
--- a/dev-ml/camlp5/ChangeLog
+++ b/dev-ml/camlp5/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/camlp5
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.54 2011/01/20 19:40:10 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.55 2011/04/19 18:31:24 aballier Exp $
+
+*camlp5-6.02.2_p3 (19 Apr 2011)
+
+ 19 Apr 2011; Alexis Ballier <aballier@gentoo.org> +camlp5-6.02.2_p3.ebuild:
+ version bump
20 Jan 2011; Alexis Ballier <aballier@gentoo.org> -camlp5-6.02.1.ebuild:
remove old
diff --git a/dev-ml/camlp5/camlp5-6.02.2_p3.ebuild b/dev-ml/camlp5/camlp5-6.02.2_p3.ebuild
new file mode 100644
index 000000000000..6340c01f442f
--- /dev/null
+++ b/dev-ml/camlp5/camlp5-6.02.2_p3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/camlp5-6.02.2_p3.ebuild,v 1.1 2011/04/19 18:31:25 aballier Exp $
+
+EAPI="2"
+
+inherit multilib findlib eutils
+
+MY_P=${P%_p*}
+DESCRIPTION="A preprocessor-pretty-printer of ocaml"
+HOMEPAGE="http://pauillac.inria.fr/~ddr/camlp5/"
+SRC_URI="http://pauillac.inria.fr/~ddr/camlp5/distrib/src/${MY_P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="doc +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.10[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+PATCHLEVEL=${PV#*_p}
+PATCHLIST=""
+
+if [ -n "${PATCHLEVEL}" ] ; then
+ for i in $(seq 1 ${PATCHLEVEL}) ; do
+ SRC_URI="${SRC_URI}
+ http://pauillac.inria.fr/~ddr/camlp5/distrib/src/patch-${PV%_p*}-${i} -> ${MY_P}-patch-${i}.patch"
+ PATCHLIST="${PATCHLIST} ${MY_P}-patch-${i}.patch"
+ done
+fi
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ for i in ${PATCHLIST} ; do
+ epatch "${DISTDIR}/${i}"
+ done
+}
+
+src_configure() {
+ ./configure \
+ -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/$(get_libdir)/ocaml \
+ -mandir /usr/share/man || die "configure failed"
+}
+
+src_compile(){
+ emake || die "emake failed"
+ if use ocamlopt; then
+ emake opt || die "Compiling native code programs failed"
+ emake opt.opt || die "Compiling native code programs failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ # findlib support
+ insinto "$(ocamlfind printconf destdir)/${PN}"
+ doins etc/META || die "failed to install META file for findlib support"
+
+ use doc && dohtml -r doc/*
+
+ dodoc CHANGES DEVEL ICHANGES README UPGRADING MODE
+}