summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-02-05 14:42:26 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-02-05 14:42:26 +0000
commit822ae689a84153c5d813e5ee854f92aae00dbe22 (patch)
treebe46bb2a32a8b2225d78c2e612978559bd97a79b /dev-ml
parentversion bump (Manifest recommit) (diff)
downloadgentoo-2-822ae689a84153c5d813e5ee854f92aae00dbe22.tar.gz
gentoo-2-822ae689a84153c5d813e5ee854f92aae00dbe22.tar.bz2
gentoo-2-822ae689a84153c5d813e5ee854f92aae00dbe22.zip
ocamlweb literate programming tool.
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamlweb/ChangeLog11
-rw-r--r--dev-ml/ocamlweb/Manifest2
-rw-r--r--dev-ml/ocamlweb/files/digest-ocamlweb-1.341
-rw-r--r--dev-ml/ocamlweb/metadata.xml5
-rw-r--r--dev-ml/ocamlweb/ocamlweb-1.34.ebuild40
5 files changed, 59 insertions, 0 deletions
diff --git a/dev-ml/ocamlweb/ChangeLog b/dev-ml/ocamlweb/ChangeLog
new file mode 100644
index 000000000000..bf995ca9d2eb
--- /dev/null
+++ b/dev-ml/ocamlweb/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-ml/ocamlweb
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlweb/ChangeLog,v 1.1 2004/02/05 14:42:26 mattam Exp $
+
+*ocamlweb-1.34 (05 Feb 2004)
+
+ 05 Feb 2004; Matthieu Sozeau <mattam@gentoo.org> metadata.xml,
+ ocamlweb-1.34.ebuild:
+ ocamlweb is a literate programming tool for ocaml, it can output TeX docs
+ from literate sources.
+
diff --git a/dev-ml/ocamlweb/Manifest b/dev-ml/ocamlweb/Manifest
new file mode 100644
index 000000000000..f42b1cd5f3e8
--- /dev/null
+++ b/dev-ml/ocamlweb/Manifest
@@ -0,0 +1,2 @@
+MD5 b6cc784d7919b5b6aefbdd958ebb17c8 ocamlweb-1.34.ebuild 646
+MD5 bf8b3a252ad256f2da01fcecfdd539a8 files/digest-ocamlweb-1.34 65
diff --git a/dev-ml/ocamlweb/files/digest-ocamlweb-1.34 b/dev-ml/ocamlweb/files/digest-ocamlweb-1.34
new file mode 100644
index 000000000000..0cda1b8082e3
--- /dev/null
+++ b/dev-ml/ocamlweb/files/digest-ocamlweb-1.34
@@ -0,0 +1 @@
+MD5 901b36d5b3b3305bce679d10b2a57af6 ocamlweb-1.34.tar.gz 118959
diff --git a/dev-ml/ocamlweb/metadata.xml b/dev-ml/ocamlweb/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/ocamlweb/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>
diff --git a/dev-ml/ocamlweb/ocamlweb-1.34.ebuild b/dev-ml/ocamlweb/ocamlweb-1.34.ebuild
new file mode 100644
index 000000000000..f14566b7be60
--- /dev/null
+++ b/dev-ml/ocamlweb/ocamlweb-1.34.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlweb/ocamlweb-1.34.ebuild,v 1.1 2004/02/05 14:42:26 mattam Exp $
+
+DESCRIPTION="O'Caml literate programming tool"
+HOMEPAGE="http://www.lri.fr/~filliatr/ocamlweb/"
+SRC_URI="http://www.lri.fr/~filliatr/ftp/ocamlweb/${P}.tar.gz"
+
+IUSE=""
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND=">=dev-lang/ocaml-3.06
+virtual/tetex"
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ emake UPDATETEX="" prefix=${D}/usr MANDIR=${D}/usr/share/man install || die
+ dodoc README COPYING CHANGES
+}
+
+tex_regen() {
+ einfo "Regenerating TeX database..."
+ /usr/bin/mktexlsr /usr/share/texmf /var/spool/texmf > /dev/null
+ eend $?
+}
+
+pkg_postinst() {
+ tex_regen
+}
+
+pkg_postrm() {
+ tex_regen
+}