summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-01-03 15:09:12 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-01-03 15:09:12 +0000
commit799b1127dcb15da7f2fba29825d80c1e15e59bf0 (patch)
treeb8399a90d285ed760e09cf808d69fd6d3479fe0d /dev-ml
parentCleanup. (diff)
downloadgentoo-2-799b1127dcb15da7f2fba29825d80c1e15e59bf0.tar.gz
gentoo-2-799b1127dcb15da7f2fba29825d80c1e15e59bf0.tar.bz2
gentoo-2-799b1127dcb15da7f2fba29825d80c1e15e59bf0.zip
version bump
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/sexplib/ChangeLog9
-rw-r--r--dev-ml/sexplib/sexplib-4.2.17.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/dev-ml/sexplib/ChangeLog b/dev-ml/sexplib/ChangeLog
index 41b902cc32a8..44980d79f340 100644
--- a/dev-ml/sexplib/ChangeLog
+++ b/dev-ml/sexplib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/sexplib
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/sexplib/ChangeLog,v 1.3 2009/10/13 07:05:11 aballier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/sexplib/ChangeLog,v 1.4 2010/01/03 15:09:12 aballier Exp $
+
+*sexplib-4.2.17 (03 Jan 2010)
+
+ 03 Jan 2010; Alexis Ballier <aballier@gentoo.org> +sexplib-4.2.17.ebuild:
+ version bump
*sexplib-4.2.16 (13 Oct 2009)
diff --git a/dev-ml/sexplib/sexplib-4.2.17.ebuild b/dev-ml/sexplib/sexplib-4.2.17.ebuild
new file mode 100644
index 000000000000..ced6f956407f
--- /dev/null
+++ b/dev-ml/sexplib/sexplib-4.2.17.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/sexplib/sexplib-4.2.17.ebuild,v 1.1 2010/01/03 15:09:12 aballier Exp $
+
+EAPI="2"
+
+inherit findlib
+
+DESCRIPTION="Library for automated conversion of OCaml-values to and from S-expressions"
+HOMEPAGE="http://www.ocaml.info/home/ocaml_sources.html"
+SRC_URI="http://ocaml.info/ocaml_sources/${PN}310-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+S=${WORKDIR}/${PN}310-${PV}/lib
+
+DEPEND=">=dev-lang/ocaml-3.10[ocamlopt]
+ dev-ml/type-conv"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake -j1 || die
+}
+
+src_test() {
+ cd "${S}/../lib_test"
+ emake -j1 || die
+ ./conv_test || die
+ ./sexp_test < test.sexp || die
+}
+
+src_install() {
+ findlib_src_preinst
+ emake install || die "make install failed"
+ dodoc ../README.txt ../Changelog
+}