summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-06-22 08:22:06 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-06-22 08:22:06 +0000
commit731384f8e76af235ec8a0186c7770ab9a18ddc2c (patch)
tree60386a52fd62565406c80bc94a8199247be0af2d /dev-ml
parentVersion bump (diff)
downloadgentoo-2-731384f8e76af235ec8a0186c7770ab9a18ddc2c.tar.gz
gentoo-2-731384f8e76af235ec8a0186c7770ab9a18ddc2c.tar.bz2
gentoo-2-731384f8e76af235ec8a0186c7770ab9a18ddc2c.zip
version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/lablgl/ChangeLog7
-rw-r--r--dev-ml/lablgl/lablgl-1.04.ebuild88
2 files changed, 94 insertions, 1 deletions
diff --git a/dev-ml/lablgl/ChangeLog b/dev-ml/lablgl/ChangeLog
index 28244106d29e..396aadb108ff 100644
--- a/dev-ml/lablgl/ChangeLog
+++ b/dev-ml/lablgl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/lablgl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/ChangeLog,v 1.52 2009/06/21 13:29:11 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/ChangeLog,v 1.53 2009/06/22 08:22:06 aballier Exp $
+
+*lablgl-1.04 (22 Jun 2009)
+
+ 22 Jun 2009; Alexis Ballier <aballier@gentoo.org> +lablgl-1.04.ebuild:
+ version bump
21 Jun 2009; Alexis Ballier <aballier@gentoo.org> lablgl-1.03-r1.ebuild:
define eapi before inherit and explicitly assign rdepend
diff --git a/dev-ml/lablgl/lablgl-1.04.ebuild b/dev-ml/lablgl/lablgl-1.04.ebuild
new file mode 100644
index 000000000000..4fbd2d07b3d0
--- /dev/null
+++ b/dev-ml/lablgl/lablgl-1.04.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgl/lablgl-1.04.ebuild,v 1.1 2009/06/22 08:22:06 aballier Exp $
+
+EAPI="2"
+
+inherit multilib eutils toolchain-funcs
+
+IUSE="doc glut +ocamlopt tk"
+
+DESCRIPTION="Objective CAML interface for OpenGL"
+HOMEPAGE="http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/lablgl.html"
+LICENSE="BSD"
+
+RDEPEND=">=dev-lang/ocaml-3.10.2[tk?,ocamlopt?]
+ virtual/opengl
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libX11
+ glut? ( virtual/glut )
+ tk? ( >=dev-lang/tcl-8.3
+ >=dev-lang/tk-8.3 )"
+DEPEND="${RDEPEND}"
+
+SRC_URI="http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/dist/${P}.tar.gz"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+S=${WORKDIR}/lablGL-${PV}
+
+src_configure() {
+ # make configuration file
+ echo "BINDIR=/usr/bin" > Makefile.config
+ echo "GLLIBS = -lGL -lGLU" >> Makefile.config
+ if use glut; then
+ echo "GLUTLIBS = -lglut" >> Makefile.config
+ else
+ echo "GLUTLIBS = " >> Makefile.config
+ fi
+ echo "XLIBS = -lXext -lXmu -lX11" >> Makefile.config
+ echo "RANLIB = $(tc-getRANLIB)" >> Makefile.config
+ echo 'COPTS = -c -O $(CFLAGS)' >> Makefile.config
+ echo 'INCLUDES = $(TKINCLUDES) $(GLINCLUDES) $(XINCLUDES)' >> Makefile.config
+}
+
+src_compile() {
+ if use tk; then
+ emake -j1 togl || die "failed to build togl"
+ if use ocamlopt; then
+ emake -j1 toglopt || die "failed to build native code togl"
+ fi
+ fi
+
+ emake -j1 lib || die "failed to build the library"
+ if use ocamlopt; then
+ emake -j1 libopt || die "failed to build native code library"
+ fi
+
+ if use glut; then
+ emake -j1 glut || die "failed to build glut"
+ if use ocamlopt; then
+ emake -j1 glutopt || die "failed to build native code glutopt"
+ fi
+ fi
+}
+
+src_install () {
+ # Makefile do not use mkdir so the library is not installed
+ # but copied as a 'stublibs' file.
+ dodir /usr/$(get_libdir)/ocaml/stublibs
+
+ # Same for lablglut's toplevel
+ dodir /usr/bin
+
+ BINDIR=${D}/usr/bin
+ BASE=${D}/usr/$(get_libdir)/ocaml
+ emake BINDIR="${BINDIR}" INSTALLDIR="${BASE}/lablGL" DLLDIR="${BASE}/stublibs" install || die "make install failed"
+
+ dodoc README CHANGES
+
+ if use doc ; then
+ insinto /usr/share/doc/${PF}
+ mv Togl/examples{,.togl}
+ doins -r Togl/examples.togl
+
+ mv LablGlut/examples{,.glut}
+ doins -r LablGlut/examples.glut
+ fi
+}