summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-02-11 03:08:27 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-02-11 03:08:27 +0000
commit5f7c4d43b3eb745de76c64be1338b35743f48188 (patch)
tree8921e7d1660b7a633bf93cb3f4fc36105cb505bc /dev-ml
parentAdd pypy. (diff)
downloadgentoo-2-5f7c4d43b3eb745de76c64be1338b35743f48188.tar.gz
gentoo-2-5f7c4d43b3eb745de76c64be1338b35743f48188.tar.bz2
gentoo-2-5f7c4d43b3eb745de76c64be1338b35743f48188.zip
eapi5, add subslot and use := deps
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamlnet/ChangeLog5
-rw-r--r--dev-ml/ocamlnet/ocamlnet-3.6.3.ebuild22
2 files changed, 15 insertions, 12 deletions
diff --git a/dev-ml/ocamlnet/ChangeLog b/dev-ml/ocamlnet/ChangeLog
index e942f03d3589..5f3ea306ca94 100644
--- a/dev-ml/ocamlnet/ChangeLog
+++ b/dev-ml/ocamlnet/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/ocamlnet
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.67 2013/02/04 12:44:20 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.68 2013/02/11 03:08:27 aballier Exp $
+
+ 11 Feb 2013; Alexis Ballier <aballier@gentoo.org> ocamlnet-3.6.3.ebuild:
+ eapi5, add subslot and use := deps
*ocamlnet-3.6.3 (04 Feb 2013)
diff --git a/dev-ml/ocamlnet/ocamlnet-3.6.3.ebuild b/dev-ml/ocamlnet/ocamlnet-3.6.3.ebuild
index eb81f9a776fa..bbbbd113a455 100644
--- a/dev-ml/ocamlnet/ocamlnet-3.6.3.ebuild
+++ b/dev-ml/ocamlnet/ocamlnet-3.6.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-3.6.3.ebuild,v 1.1 2013/02/04 12:44:20 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-3.6.3.ebuild,v 1.2 2013/02/11 03:08:27 aballier Exp $
-EAPI="2"
+EAPI="5"
inherit eutils findlib
@@ -12,7 +12,7 @@ HOMEPAGE="http://projects.camlcity.org/projects/ocamlnet.html"
SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
LICENSE="ZLIB GPL-2"
-SLOT="0"
+SLOT="0/${PV}"
KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
IUSE="cryptokit gtk ssl tk httpd +ocamlopt +pcre zip"
RESTRICT="installsources"
@@ -21,12 +21,12 @@ RESTRICT="installsources"
# ocaml-cryptgps, which is not available.
DEPEND=">=dev-ml/findlib-1.0
- pcre? ( >=dev-ml/pcre-ocaml-5 )
- >=dev-lang/ocaml-3.10.2[tk?,ocamlopt?]
- cryptokit? ( dev-ml/cryptokit )
- gtk? ( >=dev-ml/lablgtk-2 )
- ssl? ( >=dev-ml/ocaml-ssl-0.4 )
- zip? ( dev-ml/camlzip )
+ pcre? ( >=dev-ml/pcre-ocaml-5:= )
+ >=dev-lang/ocaml-3.10.2:=[tk?,ocamlopt?]
+ cryptokit? ( dev-ml/cryptokit:= )
+ gtk? ( >=dev-ml/lablgtk-2:= )
+ ssl? ( >=dev-ml/ocaml-ssl-0.4:= )
+ zip? ( dev-ml/camlzip:= )
"
RDEPEND="${DEPEND}"
@@ -63,9 +63,9 @@ src_configure() {
}
src_compile() {
- emake -j1 all || die "make failed"
+ emake -j1 all
if use ocamlopt; then
- emake -j1 opt || die "make failed"
+ emake -j1 opt
fi
}