summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-11-02 15:05:41 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-11-02 15:05:41 +0000
commit49cac6c88a21cde2ed09186dc036cb06bbf33c25 (patch)
tree989905ce2a63ef95979f64ad54dea52accb376eb /dev-ml
parentx86 stable wrt bug #389013 (diff)
downloadgentoo-2-49cac6c88a21cde2ed09186dc036cb06bbf33c25.tar.gz
gentoo-2-49cac6c88a21cde2ed09186dc036cb06bbf33c25.tar.bz2
gentoo-2-49cac6c88a21cde2ed09186dc036cb06bbf33c25.zip
version bump
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamlnet/ChangeLog7
-rw-r--r--dev-ml/ocamlnet/ocamlnet-3.4.1.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/dev-ml/ocamlnet/ChangeLog b/dev-ml/ocamlnet/ChangeLog
index e3bab4fa20bd..ccc104e4e768 100644
--- a/dev-ml/ocamlnet/ChangeLog
+++ b/dev-ml/ocamlnet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocamlnet
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.53 2011/09/09 15:25:49 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.54 2011/11/02 15:05:41 aballier Exp $
+
+*ocamlnet-3.4.1 (02 Nov 2011)
+
+ 02 Nov 2011; Alexis Ballier <aballier@gentoo.org> +ocamlnet-3.4.1.ebuild:
+ version bump
*ocamlnet-3.4 (09 Sep 2011)
diff --git a/dev-ml/ocamlnet/ocamlnet-3.4.1.ebuild b/dev-ml/ocamlnet/ocamlnet-3.4.1.ebuild
new file mode 100644
index 000000000000..6de147922996
--- /dev/null
+++ b/dev-ml/ocamlnet/ocamlnet-3.4.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-3.4.1.ebuild,v 1.1 2011/11/02 15:05:41 aballier Exp $
+
+EAPI="2"
+
+inherit eutils findlib
+
+MY_P=${P/_beta/test}
+DESCRIPTION="Modules for OCaml application-level Internet protocols"
+HOMEPAGE="http://projects.camlcity.org/projects/ocamlnet.html"
+SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
+
+LICENSE="as-is GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="cryptokit gtk ssl tk httpd +ocamlopt +pcre zip"
+RESTRICT="installsources"
+
+# the auth-dh compile flag has been disabled as well, since it depends on
+# ocaml-cryptgps, which is not available.
+
+DEPEND=">=dev-ml/findlib-1.0
+ pcre? ( >=dev-ml/pcre-ocaml-5 )
+ >=dev-lang/ocaml-3.10.2[tk?,ocamlopt?]
+ cryptokit? ( dev-ml/cryptokit )
+ gtk? ( >=dev-ml/lablgtk-2 )
+ ssl? ( >=dev-ml/ocaml-ssl-0.4 )
+ zip? ( dev-ml/camlzip )
+ "
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+ocamlnet_use_with() {
+ if use $1; then
+ echo "-with-$2"
+ else
+ echo "-without-$2"
+ fi
+}
+
+ocamlnet_use_enable() {
+ if use $1; then
+ echo "-enable-$2"
+ else
+ echo "-disable-$2"
+ fi
+}
+
+src_configure() {
+ ./configure \
+ -bindir /usr/bin \
+ -datadir /usr/share/${PN} \
+ $(ocamlnet_use_enable cryptokit crypto) \
+ $(ocamlnet_use_enable gtk gtk2) \
+ $(ocamlnet_use_enable pcre pcre) \
+ $(ocamlnet_use_enable ssl ssl) \
+ $(ocamlnet_use_enable tk tcl) \
+ $(ocamlnet_use_enable zip zip) \
+ $(ocamlnet_use_with httpd nethttpd) \
+ || die "Error : econf failed!"
+}
+
+src_compile() {
+ emake -j1 all || die "make failed"
+ if use ocamlopt; then
+ emake -j1 opt || die "make failed"
+ fi
+}
+
+src_install() {
+ export STRIP_MASK="*/bin/*"
+ findlib_src_install
+}