summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-05-24 17:13:23 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-05-24 17:13:23 +0000
commit4860aec6999938b201fb6b34172bab709dd50ba1 (patch)
treef6fd2e85e29d6aa4c2a01bf9954cbb7851176a7e /dev-ml
parentAdd USE flags to control all the optional deps. (diff)
downloadgentoo-2-4860aec6999938b201fb6b34172bab709dd50ba1.tar.gz
gentoo-2-4860aec6999938b201fb6b34172bab709dd50ba1.tar.bz2
gentoo-2-4860aec6999938b201fb6b34172bab709dd50ba1.zip
version bump
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/async_extra/ChangeLog8
-rw-r--r--dev-ml/async_extra/async_extra-109.22.00.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-ml/async_extra/ChangeLog b/dev-ml/async_extra/ChangeLog
index 3877b44713f8..933f18fd854a 100644
--- a/dev-ml/async_extra/ChangeLog
+++ b/dev-ml/async_extra/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/async_extra
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/async_extra/ChangeLog,v 1.1 2013/03/06 17:13:58 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/async_extra/ChangeLog,v 1.2 2013/05/24 17:13:23 aballier Exp $
+
+*async_extra-109.22.00 (24 May 2013)
+
+ 24 May 2013; Alexis Ballier <aballier@gentoo.org>
+ +async_extra-109.22.00.ebuild:
+ version bump
*async_extra-109.11.00 (06 Mar 2013)
diff --git a/dev-ml/async_extra/async_extra-109.22.00.ebuild b/dev-ml/async_extra/async_extra-109.22.00.ebuild
new file mode 100644
index 000000000000..d937f895db70
--- /dev/null
+++ b/dev-ml/async_extra/async_extra-109.22.00.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/async_extra/async_extra-109.22.00.ebuild,v 1.1 2013/05/24 17:13:23 aballier Exp $
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Jane Street Capital's asynchronous execution library (extra)"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV}/individual/${MY_P}.tar.gz
+ http://dev.gentoo.org/~aballier/distfiles/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-4.00.0:=
+ >=dev-ml/sexplib-109.20.00:=
+ >=dev-ml/fieldslib-109.20.00:=
+ >=dev-ml/bin-prot-109.15.00:=
+ >=dev-ml/pa_ounit-109.18.00:=
+ >=dev-ml/pipebang-109.15.00:=
+ >=dev-ml/core-109.22.00:=
+ >=dev-ml/async_core-109.22.00:=
+ >=dev-ml/async_unix-109.21.00:=
+ "
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"