summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-10-05 07:54:53 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-10-05 07:54:53 +0000
commit3c00610d656f7b5ed37a1392fef89eacf41f1112 (patch)
tree2fab2cdb4db1bcff013553052eb1be67d687fede /dev-ml
parentStable on x86, ppc and alpha. (Manifest recommit) (diff)
downloadgentoo-2-3c00610d656f7b5ed37a1392fef89eacf41f1112.tar.gz
gentoo-2-3c00610d656f7b5ed37a1392fef89eacf41f1112.tar.bz2
gentoo-2-3c00610d656f7b5ed37a1392fef89eacf41f1112.zip
New ebuild, ocaml dependency sorter. Fixes bug #25343.
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamldsort/ChangeLog8
-rw-r--r--dev-ml/ocamldsort/Manifest2
-rw-r--r--dev-ml/ocamldsort/files/digest-ocamldsort-0.14.21
-rw-r--r--dev-ml/ocamldsort/metadata.xml8
-rw-r--r--dev-ml/ocamldsort/ocamldsort-0.14.2.ebuild29
5 files changed, 48 insertions, 0 deletions
diff --git a/dev-ml/ocamldsort/ChangeLog b/dev-ml/ocamldsort/ChangeLog
new file mode 100644
index 000000000000..fa1ab7abddec
--- /dev/null
+++ b/dev-ml/ocamldsort/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-ml/ocamldsort
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamldsort/ChangeLog,v 1.1 2004/10/05 07:54:53 mattam Exp $
+
+ 04 Oct 2004; Matthieu Sozeau <mattam@gentoo.org> +ocamldsort-0.14.2
+ +metadata.xml:
+ New ebuild, ocaml dependency sorter. Fixes bug #25343.
+
diff --git a/dev-ml/ocamldsort/Manifest b/dev-ml/ocamldsort/Manifest
new file mode 100644
index 000000000000..567b4eaff433
--- /dev/null
+++ b/dev-ml/ocamldsort/Manifest
@@ -0,0 +1,2 @@
+MD5 145bbe2ed4e7bea1908ed62d02fed069 ocamldsort-0.14.2.ebuild 529
+MD5 8066f7e2bb642d8707a294dfe67e029a files/digest-ocamldsort-0.14.2 68
diff --git a/dev-ml/ocamldsort/files/digest-ocamldsort-0.14.2 b/dev-ml/ocamldsort/files/digest-ocamldsort-0.14.2
new file mode 100644
index 000000000000..12d18859d64d
--- /dev/null
+++ b/dev-ml/ocamldsort/files/digest-ocamldsort-0.14.2
@@ -0,0 +1 @@
+MD5 c43694ed1e49493286c31dc57b2038f7 ocamldsort-0.14.2.tar.gz 36434
diff --git a/dev-ml/ocamldsort/metadata.xml b/dev-ml/ocamldsort/metadata.xml
new file mode 100644
index 000000000000..764992cdaa94
--- /dev/null
+++ b/dev-ml/ocamldsort/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+ <maintainer>
+ <email>mattam@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-ml/ocamldsort/ocamldsort-0.14.2.ebuild b/dev-ml/ocamldsort/ocamldsort-0.14.2.ebuild
new file mode 100644
index 000000000000..c3f2191fcede
--- /dev/null
+++ b/dev-ml/ocamldsort/ocamldsort-0.14.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamldsort/ocamldsort-0.14.2.ebuild,v 1.1 2004/10/05 07:54:53 mattam Exp $
+
+DESCRIPTION="A dependency sorter for OCaml source files"
+HOMEPAGE="http://dimitri.mutu.net/ocaml.html"
+
+SRC_URI="ftp://quatramaran.ens.fr/pub/ara/ocamldsort/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+
+SLOT="0"
+
+KEYWORDS="x86 ppc"
+
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-3.06"
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make BINDIR=${D}/usr/bin MANDIR=${D}/usr/share/man install
+ dodoc README
+}
+