summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-03-27 21:08:38 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-03-27 21:08:38 +0000
commit2ed2c7e46d99663e402e8b93a5b629ac9f5fa96a (patch)
treea9bd04d0ff9b7185890b8cd12b9dc712880e5fa9 /dev-ml
parentversion bump (diff)
downloadgentoo-2-2ed2c7e46d99663e402e8b93a5b629ac9f5fa96a.tar.gz
gentoo-2-2ed2c7e46d99663e402e8b93a5b629ac9f5fa96a.tar.bz2
gentoo-2-2ed2c7e46d99663e402e8b93a5b629ac9f5fa96a.zip
convert to oasis.eclass
(Portage version: 2.2.0_alpha95/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/sexplib/ChangeLog5
-rw-r--r--dev-ml/sexplib/sexplib-7.0.4.ebuild29
2 files changed, 12 insertions, 22 deletions
diff --git a/dev-ml/sexplib/ChangeLog b/dev-ml/sexplib/ChangeLog
index 0bf9bccf41ba..ecd75f3b61a0 100644
--- a/dev-ml/sexplib/ChangeLog
+++ b/dev-ml/sexplib/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/sexplib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/sexplib/ChangeLog,v 1.14 2012/02/23 20:39:23 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/sexplib/ChangeLog,v 1.15 2012/03/27 21:08:38 aballier Exp $
+
+ 27 Mar 2012; Alexis Ballier <aballier@gentoo.org> sexplib-7.0.4.ebuild:
+ convert to oasis.eclass
23 Feb 2012; Alexis Ballier <aballier@gentoo.org> -sexplib-5.2.1.ebuild:
remove old
diff --git a/dev-ml/sexplib/sexplib-7.0.4.ebuild b/dev-ml/sexplib/sexplib-7.0.4.ebuild
index db948e7613e3..1e9454879b9a 100644
--- a/dev-ml/sexplib/sexplib-7.0.4.ebuild
+++ b/dev-ml/sexplib/sexplib-7.0.4.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/sexplib/sexplib-7.0.4.ebuild,v 1.1 2011/10/06 20:03:02 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/sexplib/sexplib-7.0.4.ebuild,v 1.2 2012/03/27 21:08:38 aballier Exp $
EAPI=3
-inherit findlib eutils multilib
+inherit oasis
DESCRIPTION="Library for automated conversion of OCaml-values to and from S-expressions"
HOMEPAGE="http://forge.ocamlcore.org/projects/sexplib/"
@@ -13,28 +13,16 @@ SRC_URI="http://forge.ocamlcore.org/frs/download.php/699/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="debug doc +ocamlopt"
+IUSE="doc"
-RDEPEND=">=dev-lang/ocaml-3.12[ocamlopt?]
- >=dev-ml/type-conv-3.0.4"
+RDEPEND=">=dev-ml/type-conv-3.0.4"
DEPEND="${RDEPEND}
doc? ( virtual/latex-base dev-texlive/texlive-latexextra )"
-oasis_use_enable() {
- echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
-}
-
-src_configure() {
- ./configure --prefix usr \
- --libdir /usr/$(get_libdir) \
- --destdir "${D}" \
- $(oasis_use_enable debug debug) \
- $(oasis_use_enable ocamlopt is_native) \
- || die
-}
+DOCS=( "README.txt" "Changelog" )
src_compile() {
- emake || die
+ oasis_src_compile
if use doc ; then
cd "${S}/doc"
pdflatex README || die
@@ -43,9 +31,8 @@ src_compile() {
}
src_install() {
- findlib_src_install
+ oasis_src_install
- dodoc README.txt Changelog || die
if use doc; then
dodoc doc/README.pdf || die
fi