summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-07-05 02:06:09 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-07-05 02:06:09 +0000
commit2b7aa2a6c1722c765de227e2232abf62e6aa282b (patch)
treef6b40524ba7ea76c6ada0bc4eaca90ece940980c /dev-ml
parentVersion bump. (diff)
downloadgentoo-2-2b7aa2a6c1722c765de227e2232abf62e6aa282b.tar.gz
gentoo-2-2b7aa2a6c1722c765de227e2232abf62e6aa282b.tar.bz2
gentoo-2-2b7aa2a6c1722c765de227e2232abf62e6aa282b.zip
version bump
(Portage version: 2.2.0_alpha115/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-sqlite3/ChangeLog10
-rw-r--r--dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.6.3.ebuild48
2 files changed, 56 insertions, 2 deletions
diff --git a/dev-ml/ocaml-sqlite3/ChangeLog b/dev-ml/ocaml-sqlite3/ChangeLog
index c0b933492c46..20e2acb16086 100644
--- a/dev-ml/ocaml-sqlite3/ChangeLog
+++ b/dev-ml/ocaml-sqlite3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/ocaml-sqlite3
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ChangeLog,v 1.24 2011/07/06 18:33:26 aballier Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ChangeLog,v 1.25 2012/07/05 02:06:09 aballier Exp $
+
+*ocaml-sqlite3-1.6.3 (05 Jul 2012)
+
+ 05 Jul 2012; Alexis Ballier <aballier@gentoo.org>
+ +ocaml-sqlite3-1.6.3.ebuild:
+ version bump
06 Jul 2011; Alexis Ballier <aballier@gentoo.org>
-ocaml-sqlite3-1.5.9.ebuild:
diff --git a/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.6.3.ebuild b/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.6.3.ebuild
new file mode 100644
index 000000000000..5138764e5751
--- /dev/null
+++ b/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.6.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.6.3.ebuild,v 1.1 2012/07/05 02:06:09 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+IUSE="doc +ocamlopt"
+
+MY_P="sqlite3-ocaml-${PV}"
+DESCRIPTION="A package for ocaml that provides access to SQLite databases."
+SRC_URI="http://bitbucket.org/mmottl/sqlite3-ocaml/downloads/${MY_P}.tar.gz"
+HOMEPAGE="http://bitbucket.org/mmottl/sqlite3-ocaml"
+
+DEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]
+ >=dev-db/sqlite-3.3.3"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.22.0-destdir.patch"
+ epatch "${FILESDIR}/${PN}-0.23.0-noocamlopt.patch"
+ epatch "${FILESDIR}/${PN}-1.5.1-werror.patch"
+}
+
+src_compile() {
+ emake -j1 bytecode || die "make bytecode failed"
+ if use ocamlopt; then
+ emake -j1 opt || die "make opt failed"
+ fi
+ if use doc; then
+ emake -j1 docs || die "make doc failed"
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ export OCAMLPATH="${OCAMLFIND_DESTDIR}"
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc Changelog README.txt TODO
+ use doc && dohtml doc/*
+}