summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-10-08 12:18:28 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-10-08 12:18:28 +0000
commit2555045e2f35edc0665d906441d6b0bed35310cc (patch)
tree6768daa8cdb93c8a948a62722ef0e404e08c420e /dev-ml
parentStable on amd64 wrt bug #437022 (diff)
downloadgentoo-2-2555045e2f35edc0665d906441d6b0bed35310cc.tar.gz
gentoo-2-2555045e2f35edc0665d906441d6b0bed35310cc.tar.bz2
gentoo-2-2555045e2f35edc0665d906441d6b0bed35310cc.zip
version bump
(Portage version: 2.2.0_alpha135/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-text/ChangeLog7
-rw-r--r--dev-ml/ocaml-text/ocaml-text-0.6.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-ml/ocaml-text/ChangeLog b/dev-ml/ocaml-text/ChangeLog
index 6260de8e87c1..98dfc778fa6a 100644
--- a/dev-ml/ocaml-text/ChangeLog
+++ b/dev-ml/ocaml-text/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocaml-text
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-text/ChangeLog,v 1.1 2012/03/28 11:37:13 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-text/ChangeLog,v 1.2 2012/10/08 12:18:28 aballier Exp $
+
+*ocaml-text-0.6 (08 Oct 2012)
+
+ 08 Oct 2012; Alexis Ballier <aballier@gentoo.org> +ocaml-text-0.6.ebuild:
+ version bump
*ocaml-text-0.5 (28 Mar 2012)
diff --git a/dev-ml/ocaml-text/ocaml-text-0.6.ebuild b/dev-ml/ocaml-text/ocaml-text-0.6.ebuild
new file mode 100644
index 000000000000..48abb35645d7
--- /dev/null
+++ b/dev-ml/ocaml-text/ocaml-text-0.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-text/ocaml-text-0.6.ebuild,v 1.1 2012/10/08 12:18:28 aballier Exp $
+
+EAPI=3
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="library for dealing with 'text'"
+HOMEPAGE="http://forge.ocamlcore.org/projects/ocaml-text/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/937/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="pcre"
+
+DEPEND="virtual/libiconv
+ pcre? ( dev-ml/pcre-ocaml[ocamlopt?] )"
+RDEPEND="${DEPEND}"
+
+DOCS=( "README" "CHANGES" "CHANGES.darcs" )
+
+src_configure() {
+ oasis_configure_opts="$(use_enable pcre)" \
+ oasis_src_configure
+}