summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-04-09 10:38:25 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-04-09 10:38:25 +0000
commit1d8c9100ae05b120fe1880890c96931464dd2353 (patch)
treed10bee1b681f7fc030860769dee3651d7cb406cd /dev-ml
parentstable x86, bug 308521 (diff)
downloadgentoo-2-1d8c9100ae05b120fe1880890c96931464dd2353.tar.gz
gentoo-2-1d8c9100ae05b120fe1880890c96931464dd2353.tar.bz2
gentoo-2-1d8c9100ae05b120fe1880890c96931464dd2353.zip
version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/postgresql-ocaml/ChangeLog8
-rw-r--r--dev-ml/postgresql-ocaml/postgresql-ocaml-1.12.5.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-ml/postgresql-ocaml/ChangeLog b/dev-ml/postgresql-ocaml/ChangeLog
index 6c475ec43268..96b1a83482d9 100644
--- a/dev-ml/postgresql-ocaml/ChangeLog
+++ b/dev-ml/postgresql-ocaml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/postgresql-ocaml
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.14 2010/02/24 10:40:17 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.15 2010/04/09 10:38:25 aballier Exp $
+
+*postgresql-ocaml-1.12.5 (09 Apr 2010)
+
+ 09 Apr 2010; Alexis Ballier <aballier@gentoo.org>
+ +postgresql-ocaml-1.12.5.ebuild:
+ version bump
*postgresql-ocaml-1.12.4 (24 Feb 2010)
diff --git a/dev-ml/postgresql-ocaml/postgresql-ocaml-1.12.5.ebuild b/dev-ml/postgresql-ocaml/postgresql-ocaml-1.12.5.ebuild
new file mode 100644
index 000000000000..31176bb2339d
--- /dev/null
+++ b/dev-ml/postgresql-ocaml/postgresql-ocaml-1.12.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/postgresql-ocaml-1.12.5.ebuild,v 1.1 2010/04/09 10:38:25 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+IUSE="examples +ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to PostgreSQL databases."
+SRC_URI="http://ocaml.info/ocaml_sources/${P}.tar.gz"
+HOMEPAGE="http://ocaml.info/home/ocaml_sources.html#toc9"
+
+DEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]
+ >=virtual/postgresql-base-7.3
+ >=virtual/postgresql-server-7.3"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_compile() {
+ cd "${S}/lib"
+ emake -j1 byte-code-library || die "failed to build byte code library"
+ if use ocamlopt; then
+ emake -j1 native-code-library || die "failed to built nativde code library"
+ fi
+}
+
+src_install () {
+ use ocamlopt || export OCAMLFIND_INSTFLAGS="-optional"
+ findlib_src_preinst
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS Changelog README.txt
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}