summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-01-13 20:31:27 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-01-13 20:31:27 +0000
commit1760fd78dce4ba1db2567cdc894945ed4909a2c5 (patch)
tree8f0381bcbb74803b71fd3c4e20b055ed453bebd7 /dev-ml
parentVersion bump, bug #451662. (diff)
downloadgentoo-2-1760fd78dce4ba1db2567cdc894945ed4909a2c5.tar.gz
gentoo-2-1760fd78dce4ba1db2567cdc894945ed4909a2c5.tar.bz2
gentoo-2-1760fd78dce4ba1db2567cdc894945ed4909a2c5.zip
version bump, bug #446730 by Jacques-Pascal Deplaix
(Portage version: 2.2.0_alpha151/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/eliom/ChangeLog9
-rw-r--r--dev-ml/eliom/eliom-3.0.3.ebuild61
2 files changed, 68 insertions, 2 deletions
diff --git a/dev-ml/eliom/ChangeLog b/dev-ml/eliom/ChangeLog
index a8e3f407ee03..e5ac494179ea 100644
--- a/dev-ml/eliom/ChangeLog
+++ b/dev-ml/eliom/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/eliom
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/eliom/ChangeLog,v 1.1 2012/08/07 20:50:07 aballier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/eliom/ChangeLog,v 1.2 2013/01/13 20:31:27 aballier Exp $
+
+*eliom-3.0.3 (13 Jan 2013)
+
+ 13 Jan 2013; Alexis Ballier <aballier@gentoo.org> +eliom-3.0.3.ebuild:
+ version bump, bug #446730 by Jacques-Pascal Deplaix
*eliom-2.2.2 (07 Aug 2012)
diff --git a/dev-ml/eliom/eliom-3.0.3.ebuild b/dev-ml/eliom/eliom-3.0.3.ebuild
new file mode 100644
index 000000000000..40d8ab7fa565
--- /dev/null
+++ b/dev-ml/eliom/eliom-3.0.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/eliom/eliom-3.0.3.ebuild,v 1.1 2013/01/13 20:31:27 aballier Exp $
+
+EAPI=4
+
+inherit eutils multilib findlib
+
+DESCRIPTION="A web framework to program client/server applications"
+HOMEPAGE="http://ocsigen.org/eliom/"
+SRC_URI="http://www.ocsigen.org/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.12[ocamlopt?]
+ >=dev-ml/js_of_ocaml-1.3.2
+ >=www-servers/ocsigenserver-2.2.0
+ >=dev-ml/tyxml-2.1
+ >=dev-ml/deriving-ocsigen-0.3
+ dev-ml/react
+ dev-ml/ocaml-ssl
+ dev-ml/calendar"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ sh configure \
+ --prefix "/usr" \
+ --docdir "/usr/share/doc/${PF}/html" \
+ --mandir "/usr/share/man/" \
+ --temproot "${ED}" \
+ --libdir "/usr/$(get_libdir)/ocaml" \
+ || die "configure failed"
+}
+
+src_compile() {
+ if use ocamlopt ; then
+ emake
+ else
+ emake byte
+ fi
+ use doc && emake doc -j1
+}
+
+src_test() {
+ emake tests.byte
+ use ocamlopt && emake tests.opt
+}
+
+src_install() {
+ findlib_src_preinst
+ if use ocamlopt; then
+ emake install
+ else
+ emake install.byte
+ fi
+ use doc && emake install.doc
+ dodoc CHANGES README
+}