summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-07-17 14:54:51 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-07-17 14:54:51 +0000
commit0db7d216e14165a0fd6fe3b802fb1774b3237c66 (patch)
treefe4360177087a2944685f0d71055e78d485476f4 /dev-ml
parentAdd missing dependencies. Fix tests wrt bug 328561. Thanks to Diego for report. (diff)
downloadgentoo-2-0db7d216e14165a0fd6fe3b802fb1774b3237c66.tar.gz
gentoo-2-0db7d216e14165a0fd6fe3b802fb1774b3237c66.tar.bz2
gentoo-2-0db7d216e14165a0fd6fe3b802fb1774b3237c66.zip
version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/camomile/ChangeLog7
-rw-r--r--dev-ml/camomile/camomile-0.8.1.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-ml/camomile/ChangeLog b/dev-ml/camomile/ChangeLog
index 4f20b0a4c7b1..2fcd6c0e2144 100644
--- a/dev-ml/camomile/ChangeLog
+++ b/dev-ml/camomile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/camomile
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camomile/ChangeLog,v 1.22 2010/07/17 12:31:21 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camomile/ChangeLog,v 1.23 2010/07/17 14:54:51 aballier Exp $
+
+*camomile-0.8.1 (17 Jul 2010)
+
+ 17 Jul 2010; Alexis Ballier <aballier@gentoo.org> +camomile-0.8.1.ebuild:
+ version bump
17 Jul 2010; Alexis Ballier <aballier@gentoo.org> -camomile-0.7.2.ebuild:
remove old
diff --git a/dev-ml/camomile/camomile-0.8.1.ebuild b/dev-ml/camomile/camomile-0.8.1.ebuild
new file mode 100644
index 000000000000..20a2061f882b
--- /dev/null
+++ b/dev-ml/camomile/camomile-0.8.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camomile/camomile-0.8.1.ebuild,v 1.1 2010/07/17 14:54:51 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+DESCRIPTION="Camomile is a comprehensive Unicode library for ocaml."
+HOMEPAGE="http://camomile.sourceforge.net/"
+SRC_URI="mirror://sourceforge/camomile/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug +ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_compile() {
+ emake -j1 byte unidata unimaps charmap_data locale_data || die "failed to build"
+ if use ocamlopt; then
+ emake -j1 opt || die "failed to build native code"
+ fi
+}
+
+src_install() {
+ dodir /usr/bin
+ findlib_src_install DATADIR="${D}/usr/share" BINDIR="${D}/usr/bin"
+}