summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-07-22 12:31:51 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-07-22 12:31:51 +0000
commit375735baaf129b94fefe65ef7c3adb563fdd8912 (patch)
tree368d66e18a9c5899c334af50879f674107a24cbd /dev-ml/utop
parentremove old (diff)
downloadgentoo-2-375735baaf129b94fefe65ef7c3adb563fdd8912.tar.gz
gentoo-2-375735baaf129b94fefe65ef7c3adb563fdd8912.tar.bz2
gentoo-2-375735baaf129b94fefe65ef7c3adb563fdd8912.zip
version bump
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/utop')
-rw-r--r--dev-ml/utop/ChangeLog7
-rw-r--r--dev-ml/utop/utop-1.5.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-ml/utop/ChangeLog b/dev-ml/utop/ChangeLog
index 485f80f91c88..dab2fe836fe8 100644
--- a/dev-ml/utop/ChangeLog
+++ b/dev-ml/utop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/utop
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/utop/ChangeLog,v 1.4 2013/03/03 14:38:19 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/utop/ChangeLog,v 1.5 2013/07/22 12:31:51 aballier Exp $
+
+*utop-1.5 (22 Jul 2013)
+
+ 22 Jul 2013; Alexis Ballier <aballier@gentoo.org> +utop-1.5.ebuild:
+ version bump
03 Mar 2013; Alexis Ballier <aballier@gentoo.org> utop-1.2.ebuild:
eapi5, use slotdeps and define subslot
diff --git a/dev-ml/utop/utop-1.5.ebuild b/dev-ml/utop/utop-1.5.ebuild
new file mode 100644
index 000000000000..56ec595a86b3
--- /dev/null
+++ b/dev-ml/utop/utop-1.5.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/utop/utop-1.5.ebuild,v 1.1 2013/07/22 12:31:51 aballier Exp $
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+inherit oasis elisp-common
+
+DESCRIPTION="A new toplevel for OCaml with completion and colorization"
+HOMEPAGE="http://forge.ocamlcore.org/projects/utop/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1169/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="emacs"
+
+DEPEND=">=dev-ml/lwt-2.4.0:=[react]
+ >=dev-ml/lambda-term-1.2:=
+ >=dev-ml/zed-1.2:=
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}"
+
+DOCS=( "CHANGES.md" "README.md" )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ sed -i "s/(\"utop.el.*)//" setup.ml
+}
+
+src_compile() {
+ oasis_src_compile
+ if use emacs; then
+ elisp-compile src/top/*.el
+ fi
+}
+
+src_install() {
+ oasis_src_install
+ if use emacs; then
+ elisp-install "${PN}" src/top/*.el src/top/*.elc || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}