summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-03-30 11:40:53 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-03-30 11:40:53 +0000
commit05c8c4be44c2da8e005627e46f117d9376647948 (patch)
treeb1eb85f8c76b4085e5e4ae2c3f9bf14368eb58ae /dev-ml/tyxml
parentinitial import, ebuild by Guillaume Horel in bug #406521 (diff)
downloadgentoo-2-05c8c4be44c2da8e005627e46f117d9376647948.tar.gz
gentoo-2-05c8c4be44c2da8e005627e46f117d9376647948.tar.bz2
gentoo-2-05c8c4be44c2da8e005627e46f117d9376647948.zip
initial import, ebuild by Guillaume Horel in bug #406515
(Portage version: 2.2.0_alpha96/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/tyxml')
-rw-r--r--dev-ml/tyxml/ChangeLog10
-rw-r--r--dev-ml/tyxml/metadata.xml8
-rw-r--r--dev-ml/tyxml/tyxml-2.0.2.ebuild46
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-ml/tyxml/ChangeLog b/dev-ml/tyxml/ChangeLog
new file mode 100644
index 000000000000..d3a05355cd1f
--- /dev/null
+++ b/dev-ml/tyxml/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ml/tyxml
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/tyxml/ChangeLog,v 1.1 2012/03/30 11:40:53 aballier Exp $
+
+*tyxml-2.0.2 (30 Mar 2012)
+
+ 30 Mar 2012; Alexis Ballier <aballier@gentoo.org> +tyxml-2.0.2.ebuild,
+ +metadata.xml:
+ initial import, ebuild by Guillaume Horel in bug #406515
+
diff --git a/dev-ml/tyxml/metadata.xml b/dev-ml/tyxml/metadata.xml
new file mode 100644
index 000000000000..ea89b16d367e
--- /dev/null
+++ b/dev-ml/tyxml/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+ <use>
+ <flag name='ocamlduce'>Enables ocamlduce XML typechecking.</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-ml/tyxml/tyxml-2.0.2.ebuild b/dev-ml/tyxml/tyxml-2.0.2.ebuild
new file mode 100644
index 000000000000..7457da1e7918
--- /dev/null
+++ b/dev-ml/tyxml/tyxml-2.0.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/tyxml/tyxml-2.0.2.ebuild,v 1.1 2012/03/30 11:40:53 aballier Exp $
+
+EAPI=4
+
+inherit eutils findlib
+
+DESCRIPTION="A libary to build xml trees typechecked by OCaml"
+HOMEPAGE="http://ocsigen.org/tyxml/"
+SRC_URI="http://www.ocsigen.org/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc ocamlduce +ocamlopt"
+
+DEPEND="
+ >=dev-lang/ocaml-3.12[ocamlopt?]
+ dev-ml/ocamlnet
+ ocamlduce? ( dev-ml/ocamlduce )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ export myopts="OCAMLDUCE=$(usex ocamlduce yes no)"
+}
+
+src_compile() {
+ if use ocamlopt; then
+ emake "$myopts"
+ else
+ emake "$myopts" byte
+ fi
+ use doc && emake doc "$myopts"
+}
+
+src_install() {
+ findlib_src_preinst
+ if use ocamlopt; then
+ emake DESTIR="${D}" OCAMLDUCE="$myopts" install
+ else
+ emake DESTIR="${D}" OCAMLDUCE="$myopts" install-byte
+ fi
+ dodoc CHANGES README
+ use doc && dohtml -r doc/api-html
+}