summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-10-06 20:00:53 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-10-06 20:00:53 +0000
commit42c91f7e502b840a1d6168c25759fdd4cea0e137 (patch)
tree244fc44becae4d2d56c1cfff7d26b96eb36d9efc /dev-ml/type-conv
parentmask new type-conv (diff)
downloadgentoo-2-42c91f7e502b840a1d6168c25759fdd4cea0e137.tar.gz
gentoo-2-42c91f7e502b840a1d6168c25759fdd4cea0e137.tar.bz2
gentoo-2-42c91f7e502b840a1d6168c25759fdd4cea0e137.zip
version bump
(Portage version: 2.2.0_alpha62/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/type-conv')
-rw-r--r--dev-ml/type-conv/ChangeLog7
-rw-r--r--dev-ml/type-conv/type-conv-3.0.4.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-ml/type-conv/ChangeLog b/dev-ml/type-conv/ChangeLog
index e0f1095c536d..fdf56bf25531 100644
--- a/dev-ml/type-conv/ChangeLog
+++ b/dev-ml/type-conv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/type-conv
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/type-conv/ChangeLog,v 1.12 2011/07/23 15:43:07 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/type-conv/ChangeLog,v 1.13 2011/10/06 20:00:53 aballier Exp $
+
+*type-conv-3.0.4 (06 Oct 2011)
+
+ 06 Oct 2011; Alexis Ballier <aballier@gentoo.org> +type-conv-3.0.4.ebuild:
+ version bump
23 Jul 2011; Thomas Kahle <tomka@gentoo.org> type-conv-2.3.0.ebuild:
~x86 per bug 373149
diff --git a/dev-ml/type-conv/type-conv-3.0.4.ebuild b/dev-ml/type-conv/type-conv-3.0.4.ebuild
new file mode 100644
index 000000000000..9186fde41a3d
--- /dev/null
+++ b/dev-ml/type-conv/type-conv-3.0.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/type-conv/type-conv-3.0.4.ebuild,v 1.1 2011/10/06 20:00:53 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils multilib
+
+DESCRIPTION="Mini library required for some other preprocessing libraries"
+HOMEPAGE="http://forge.ocamlcore.org/projects/type-conv/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/697/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc +ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.12[ocamlopt?]"
+
+DEPEND="${RDEPEND}"
+
+oasis_use_enable() {
+ echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
+}
+
+src_configure() {
+ ./configure --prefix usr \
+ --libdir /usr/$(get_libdir) \
+ --destdir "${D}" \
+ $(oasis_use_enable debug debug) \
+ $(oasis_use_enable ocamlopt is_native) \
+ || die
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}/_build/lib" emake test || die
+}
+
+src_install() {
+ findlib_src_install
+
+ dodoc README.txt Changelog || die
+}