summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-09-19 12:33:03 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-09-19 12:33:03 +0000
commitf203a44f99601eb6bee0d46a4998431463f30dcb (patch)
tree585d181b68e69badd3b15e013cb87ce3366fd0cc /dev-ml/sexplib
parentamd64/x86 stable, bug #285384 (diff)
downloadgentoo-2-f203a44f99601eb6bee0d46a4998431463f30dcb.tar.gz
gentoo-2-f203a44f99601eb6bee0d46a4998431463f30dcb.tar.bz2
gentoo-2-f203a44f99601eb6bee0d46a4998431463f30dcb.zip
Initial import, ebuild by Guillaume Horel <guillaume.horel@gmail.com>, bug #281274
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/sexplib')
-rw-r--r--dev-ml/sexplib/ChangeLog11
-rw-r--r--dev-ml/sexplib/metadata.xml5
-rw-r--r--dev-ml/sexplib/sexplib-4.2.13.ebuild38
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-ml/sexplib/ChangeLog b/dev-ml/sexplib/ChangeLog
new file mode 100644
index 000000000000..d84d47cb9074
--- /dev/null
+++ b/dev-ml/sexplib/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-ml/sexplib
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/sexplib/ChangeLog,v 1.1 2009/09/19 12:33:03 aballier Exp $
+
+*sexplib-4.2.13 (19 Sep 2009)
+
+ 19 Sep 2009; Alexis Ballier <aballier@gentoo.org> +sexplib-4.2.13.ebuild,
+ +metadata.xml:
+ Initial import, ebuild by Guillaume Horel <guillaume.horel@gmail.com>, bug
+ #281274
+
diff --git a/dev-ml/sexplib/metadata.xml b/dev-ml/sexplib/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/sexplib/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>
diff --git a/dev-ml/sexplib/sexplib-4.2.13.ebuild b/dev-ml/sexplib/sexplib-4.2.13.ebuild
new file mode 100644
index 000000000000..4d726262e158
--- /dev/null
+++ b/dev-ml/sexplib/sexplib-4.2.13.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/sexplib/sexplib-4.2.13.ebuild,v 1.1 2009/09/19 12:33:03 aballier Exp $
+
+EAPI="2"
+
+inherit findlib
+
+DESCRIPTION="Library for automated conversion of OCaml-values to and from S-expressions"
+HOMEPAGE="http://www.ocaml.info/home/ocaml_sources.html"
+SRC_URI="http://ocaml.info/ocaml_sources/${PN}310-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+S=${WORKDIR}/${PN}310-${PV}/lib
+
+DEPEND=">=dev-lang/ocaml-3.10[ocamlopt]
+ dev-ml/type-conv"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake -j1 || die
+}
+
+src_test() {
+ cd "${S}/../lib_test"
+ emake -j1 || die
+ ./conv_test || die
+ ./sexp_test < test.sexp || die
+}
+
+src_install() {
+ findlib_src_preinst
+ emake install || die "make install failed"
+ dodoc ../README.txt ../Changelog
+}