summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-02-24 20:11:52 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-02-24 20:11:52 +0000
commit76ff761458f03e11fef39e631ea002ae29128f7d (patch)
treeb7b984f8ce6947f0d2388f2509c05e9fd1330c1f /dev-ml/sexplib
parentNon-maintainer commit. (diff)
downloadgentoo-2-76ff761458f03e11fef39e631ea002ae29128f7d.tar.gz
gentoo-2-76ff761458f03e11fef39e631ea002ae29128f7d.tar.bz2
gentoo-2-76ff761458f03e11fef39e631ea002ae29128f7d.zip
version bump by Vladimir Ivanov <v.ivanov@ymail.com>, bug #355519, with improvements by me
(Portage version: 2.2.0_alpha25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/sexplib')
-rw-r--r--dev-ml/sexplib/ChangeLog10
-rw-r--r--dev-ml/sexplib/sexplib-5.2.0.ebuild54
2 files changed, 62 insertions, 2 deletions
diff --git a/dev-ml/sexplib/ChangeLog b/dev-ml/sexplib/ChangeLog
index a911b8f73b70..8fcf2e98aeb4 100644
--- a/dev-ml/sexplib/ChangeLog
+++ b/dev-ml/sexplib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/sexplib
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/sexplib/ChangeLog,v 1.5 2010/04/12 06:38:38 aballier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/sexplib/ChangeLog,v 1.6 2011/02/24 20:11:52 aballier Exp $
+
+*sexplib-5.2.0 (24 Feb 2011)
+
+ 24 Feb 2011; Alexis Ballier <aballier@gentoo.org> +sexplib-5.2.0.ebuild:
+ version bump by Vladimir Ivanov <v.ivanov@ymail.com>, bug #355519, with
+ improvements by me
12 Apr 2010; Alexis Ballier <aballier@gentoo.org> -sexplib-4.2.16.ebuild:
remove old
diff --git a/dev-ml/sexplib/sexplib-5.2.0.ebuild b/dev-ml/sexplib/sexplib-5.2.0.ebuild
new file mode 100644
index 000000000000..9ddffb344ffd
--- /dev/null
+++ b/dev-ml/sexplib/sexplib-5.2.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/sexplib/sexplib-5.2.0.ebuild,v 1.1 2011/02/24 20:11:52 aballier Exp $
+
+EAPI=3
+
+inherit findlib eutils multilib
+
+DESCRIPTION="Library for automated conversion of OCaml-values to and from S-expressions"
+HOMEPAGE="http://www.ocaml.info/home/ocaml_sources.html"
+SRC_URI="http://www.janestreet.com/ocaml/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug doc +ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]
+ dev-ml/type-conv"
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base )"
+
+S=${WORKDIR}/${PN}
+
+oasis_use_enable() {
+ echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
+}
+
+src_configure() {
+ ./configure --prefix usr \
+ --libdir /usr/$(get_libdir) \
+ --destdir "${D}" \
+ $(oasis_use_enable debug debug) \
+ $(oasis_use_enable ocamlopt is_native) \
+ || die
+}
+
+src_compile() {
+ emake || die
+ if use doc ; then
+ cd "${S}/doc"
+ pdflatex README || die
+ pdflatex README || die
+ fi
+}
+
+src_install() {
+ findlib_src_install
+
+ dodoc README Changelog || die
+ if use doc; then
+ dodoc doc/README.pdf || die
+ fi
+}