summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-04-09 07:59:20 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-04-09 07:59:20 +0000
commit72343b358dbe9afa4b7a26eef2a8f83a8cfd5e48 (patch)
tree4ce948fee3a5b25b86c7272432cd27d0f3c15ae0 /dev-ml/pxp
parentremove old (diff)
downloadgentoo-2-72343b358dbe9afa4b7a26eef2a8f83a8cfd5e48.tar.gz
gentoo-2-72343b358dbe9afa4b7a26eef2a8f83a8cfd5e48.tar.bz2
gentoo-2-72343b358dbe9afa4b7a26eef2a8f83a8cfd5e48.zip
version bump, allow building without ocamlopt, readd ~amd64
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'dev-ml/pxp')
-rw-r--r--dev-ml/pxp/ChangeLog9
-rw-r--r--dev-ml/pxp/pxp-1.2.0_beta2.ebuild55
2 files changed, 62 insertions, 2 deletions
diff --git a/dev-ml/pxp/ChangeLog b/dev-ml/pxp/ChangeLog
index da87bb2e2cf3..ccd17907c7db 100644
--- a/dev-ml/pxp/ChangeLog
+++ b/dev-ml/pxp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/pxp
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pxp/ChangeLog,v 1.12 2007/02/09 02:51:38 flameeyes Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pxp/ChangeLog,v 1.13 2008/04/09 07:59:20 aballier Exp $
+
+*pxp-1.2.0_beta2 (09 Apr 2008)
+
+ 09 Apr 2008; Alexis Ballier <aballier@gentoo.org> +pxp-1.2.0_beta2.ebuild:
+ version bump, allow building without ocamlopt, readd ~amd64
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/dev-ml/pxp/pxp-1.2.0_beta2.ebuild b/dev-ml/pxp/pxp-1.2.0_beta2.ebuild
new file mode 100644
index 000000000000..3508cf71f25d
--- /dev/null
+++ b/dev-ml/pxp/pxp-1.2.0_beta2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pxp/pxp-1.2.0_beta2.ebuild,v 1.1 2008/04/09 07:59:20 aballier Exp $
+
+EAPI="1"
+
+inherit findlib eutils
+
+MY_P=${P/_beta/test}
+
+DESCRIPTION="validating XML parser library for O'Caml"
+HOMEPAGE="http://www.ocaml-programming.de/packages/documentation/pxp/index_dev.html"
+SRC_URI="http://www.ocaml-programming.de/packages/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+SLOT="0"
+DEPEND=">=dev-ml/pcre-ocaml-4.31
+>=dev-ml/ulex-0.5
+>=dev-ml/ocamlnet-0.98
+>=dev-lang/ocaml-3.09"
+
+IUSE="examples +ocamlopt"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
+src_compile() {
+ #the included configure does not support many standard switches and is quite picky
+ ./configure || die "configure failed"
+ emake -j1 all || die "make all failed"
+ if use ocamlopt; then
+ emake -j1 opt || die "make opt failed"
+ fi
+}
+
+src_install() {
+ findlib_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+
+ cd doc
+ dodoc ABOUT-FINDLIB DEV EXTENSIONS README SPEC design.txt
+}