summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-08-18 20:27:01 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-08-18 20:27:01 +0000
commit3695b097bd1930eefb5b89db1b229f05a709a511 (patch)
treef7585ca92b441ef179ff4cef15c2fbe80127a853 /dev-ml/pxp/pxp-1.1.6.ebuild
parentAdding KDE integration patch and closing bug #58312. (Manifest recommit) (diff)
downloadgentoo-2-3695b097bd1930eefb5b89db1b229f05a709a511.tar.gz
gentoo-2-3695b097bd1930eefb5b89db1b229f05a709a511.tar.bz2
gentoo-2-3695b097bd1930eefb5b89db1b229f05a709a511.zip
Version bump, fixes bug #52575
Diffstat (limited to 'dev-ml/pxp/pxp-1.1.6.ebuild')
-rw-r--r--dev-ml/pxp/pxp-1.1.6.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/pxp/pxp-1.1.6.ebuild b/dev-ml/pxp/pxp-1.1.6.ebuild
new file mode 100644
index 000000000000..153e2292e00e
--- /dev/null
+++ b/dev-ml/pxp/pxp-1.1.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pxp/pxp-1.1.6.ebuild,v 1.1 2004/08/18 20:27:01 mattam Exp $
+
+DESCRIPTION="validating XML parser library for O'Caml"
+HOMEPAGE="http://www.ocaml-programming.de/packages/documentation/pxp/index_dev.html"
+SRC_URI="http://www.ocaml-programming.de/packages/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND=">=dev-ml/pcre-ocaml-4.31
+ >=dev-ml/ocamlnet-0.94
+ >=dev-ml/findlib-0.8"
+
+src_compile() {
+ #the included configure does not support many standard switches and is quite picky
+ ./configure || die
+ make all opt || die
+}
+
+src_install() {
+ local destdir=`ocamlfind printconf destdir`
+ dodir ${destdir}
+ make OCAMLFIND_DESTDIR=${D}${destdir} install || die
+}