summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-05-24 13:57:11 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-05-24 13:57:11 +0000
commit7c394bac3a2f28943113d9965581e44a21ffa010 (patch)
tree317d49009786d849ff547d03d0696be548e65db5 /dev-ml/postgresql-ocaml
parentRevision bump for latest genpatches. (diff)
downloadgentoo-2-7c394bac3a2f28943113d9965581e44a21ffa010.tar.gz
gentoo-2-7c394bac3a2f28943113d9965581e44a21ffa010.tar.bz2
gentoo-2-7c394bac3a2f28943113d9965581e44a21ffa010.zip
versin bump
(Portage version: 2.2.0_alpha35/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/postgresql-ocaml')
-rw-r--r--dev-ml/postgresql-ocaml/ChangeLog8
-rw-r--r--dev-ml/postgresql-ocaml/postgresql-ocaml-1.16.0.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-ml/postgresql-ocaml/ChangeLog b/dev-ml/postgresql-ocaml/ChangeLog
index c7af89691efb..6e63352e2966 100644
--- a/dev-ml/postgresql-ocaml/ChangeLog
+++ b/dev-ml/postgresql-ocaml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/postgresql-ocaml
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.21 2011/01/21 00:36:47 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.22 2011/05/24 13:57:11 aballier Exp $
+
+*postgresql-ocaml-1.16.0 (24 May 2011)
+
+ 24 May 2011; Alexis Ballier <aballier@gentoo.org>
+ +postgresql-ocaml-1.16.0.ebuild:
+ versin bump
21 Jan 2011; Alexis Ballier <aballier@gentoo.org>
-postgresql-ocaml-1.12.5.ebuild, -postgresql-ocaml-1.13.0.ebuild,
diff --git a/dev-ml/postgresql-ocaml/postgresql-ocaml-1.16.0.ebuild b/dev-ml/postgresql-ocaml/postgresql-ocaml-1.16.0.ebuild
new file mode 100644
index 000000000000..396319514001
--- /dev/null
+++ b/dev-ml/postgresql-ocaml/postgresql-ocaml-1.16.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/postgresql-ocaml-1.16.0.ebuild,v 1.1 2011/05/24 13:57:11 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+IUSE="examples +ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to PostgreSQL databases."
+SRC_URI="http://ocaml.info/ocaml_sources/${P}.tar.gz"
+HOMEPAGE="http://ocaml.info/home/ocaml_sources.html#toc9"
+
+DEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]
+ dev-db/postgresql-base
+ dev-db/postgresql-server"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_compile() {
+ cd "${S}/lib"
+ emake -j1 byte-code-library || die "failed to build byte code library"
+ if use ocamlopt; then
+ emake -j1 native-code-library || die "failed to built nativde code library"
+ fi
+}
+
+src_install () {
+ use ocamlopt || export OCAMLFIND_INSTFLAGS="-optional"
+ findlib_src_preinst
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS Changelog README.txt
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}