summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-11-10 07:30:02 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-11-10 07:30:02 +0000
commit6fa33e0214fc434cda92757de4a7edacd397064a (patch)
treea273cdb81736b727c220a9936486c67075b9f613 /dev-ml/postgresql-ocaml
parentjuno bup (diff)
downloadgentoo-2-6fa33e0214fc434cda92757de4a7edacd397064a.tar.gz
gentoo-2-6fa33e0214fc434cda92757de4a7edacd397064a.tar.bz2
gentoo-2-6fa33e0214fc434cda92757de4a7edacd397064a.zip
version bump
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/postgresql-ocaml')
-rw-r--r--dev-ml/postgresql-ocaml/ChangeLog8
-rw-r--r--dev-ml/postgresql-ocaml/postgresql-ocaml-2.1.2.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-ml/postgresql-ocaml/ChangeLog b/dev-ml/postgresql-ocaml/ChangeLog
index e23f87cbd3a6..feb1516a7578 100644
--- a/dev-ml/postgresql-ocaml/ChangeLog
+++ b/dev-ml/postgresql-ocaml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/postgresql-ocaml
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.41 2014/11/04 00:28:18 titanofold Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.42 2014/11/10 07:30:02 aballier Exp $
+
+*postgresql-ocaml-2.1.2 (10 Nov 2014)
+
+ 10 Nov 2014; Alexis Ballier <aballier@gentoo.org>
+ +postgresql-ocaml-2.1.2.ebuild:
+ version bump
04 Nov 2014; Aaron W. Swenson <titanofold@gentoo.org>
postgresql-ocaml-2.0.4.ebuild, postgresql-ocaml-2.0.5.ebuild,
diff --git a/dev-ml/postgresql-ocaml/postgresql-ocaml-2.1.2.ebuild b/dev-ml/postgresql-ocaml/postgresql-ocaml-2.1.2.ebuild
new file mode 100644
index 000000000000..ed2d8c235d80
--- /dev/null
+++ b/dev-ml/postgresql-ocaml/postgresql-ocaml-2.1.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/postgresql-ocaml-2.1.2.ebuild,v 1.1 2014/11/10 07:30:02 aballier Exp $
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="A package for ocaml that provides access to PostgreSQL databases"
+SRC_URI="https://github.com/mmottl/postgresql-ocaml/releases/download/v${PV}/${P}.tar.gz"
+HOMEPAGE="http://mmottl.github.io/postgresql-ocaml/"
+IUSE="examples"
+
+RDEPEND="
+ virtual/postgresql[server]
+"
+DEPEND="${RDEPEND}
+ >=dev-ml/findlib-1.5"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}