summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-02-02 09:39:35 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-02-02 09:39:35 +0000
commit36b1a104fa31b4928105e631459b6d69f86209ee (patch)
tree1a05e2afdf64fbad3b38ac1efae2798e941a2ebe /dev-ml/postgresql-ocaml
parentRemove old versions (diff)
downloadgentoo-2-36b1a104fa31b4928105e631459b6d69f86209ee.tar.gz
gentoo-2-36b1a104fa31b4928105e631459b6d69f86209ee.tar.bz2
gentoo-2-36b1a104fa31b4928105e631459b6d69f86209ee.zip
version bump
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/postgresql-ocaml')
-rw-r--r--dev-ml/postgresql-ocaml/ChangeLog10
-rw-r--r--dev-ml/postgresql-ocaml/postgresql-ocaml-3.0.0.ebuild34
2 files changed, 42 insertions, 2 deletions
diff --git a/dev-ml/postgresql-ocaml/ChangeLog b/dev-ml/postgresql-ocaml/ChangeLog
index 9e56078a171c..6061486ac453 100644
--- a/dev-ml/postgresql-ocaml/ChangeLog
+++ b/dev-ml/postgresql-ocaml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/postgresql-ocaml
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.43 2014/12/28 15:38:09 titanofold Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.44 2015/02/02 09:39:35 aballier Exp $
+
+*postgresql-ocaml-3.0.0 (02 Feb 2015)
+
+ 02 Feb 2015; Alexis Ballier <aballier@gentoo.org>
+ +postgresql-ocaml-3.0.0.ebuild:
+ version bump
28 Dec 2014; Aaron W. Swenson <titanofold@gentoo.org>
postgresql-ocaml-2.0.4.ebuild, postgresql-ocaml-2.0.5.ebuild,
diff --git a/dev-ml/postgresql-ocaml/postgresql-ocaml-3.0.0.ebuild b/dev-ml/postgresql-ocaml/postgresql-ocaml-3.0.0.ebuild
new file mode 100644
index 000000000000..ec05e3c6eb32
--- /dev/null
+++ b/dev-ml/postgresql-ocaml/postgresql-ocaml-3.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/postgresql-ocaml-3.0.0.ebuild,v 1.1 2015/02/02 09:39:35 aballier Exp $
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="A package for ocaml that provides access to PostgreSQL databases"
+SRC_URI="https://github.com/mmottl/postgresql-ocaml/releases/download/v${PV}/${P}.tar.gz"
+HOMEPAGE="http://mmottl.github.io/postgresql-ocaml/"
+IUSE="examples"
+
+RDEPEND="
+ dev-db/postgresql[server]
+"
+DEPEND="${RDEPEND}
+ >=dev-ml/findlib-1.5"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}