summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-10-10 11:35:32 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-10-10 11:35:32 +0000
commit84f68384b975da289bd58696d4692fd9fdf3df86 (patch)
treea09215b7d7431f6304bc980c8131922627135270 /dev-ml/postgresql-ocaml/postgresql-ocaml-2.0.2.ebuild
parentstable ppc ppc64, bug #437360 (diff)
downloadgentoo-2-84f68384b975da289bd58696d4692fd9fdf3df86.tar.gz
gentoo-2-84f68384b975da289bd58696d4692fd9fdf3df86.tar.bz2
gentoo-2-84f68384b975da289bd58696d4692fd9fdf3df86.zip
version bump
(Portage version: 2.2.0_alpha136/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/postgresql-ocaml/postgresql-ocaml-2.0.2.ebuild')
-rw-r--r--dev-ml/postgresql-ocaml/postgresql-ocaml-2.0.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/postgresql-ocaml/postgresql-ocaml-2.0.2.ebuild b/dev-ml/postgresql-ocaml/postgresql-ocaml-2.0.2.ebuild
new file mode 100644
index 000000000000..a108edb74449
--- /dev/null
+++ b/dev-ml/postgresql-ocaml/postgresql-ocaml-2.0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/postgresql-ocaml-2.0.2.ebuild,v 1.1 2012/10/10 11:35:32 aballier Exp $
+
+EAPI=4
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="A package for ocaml that provides access to PostgreSQL databases."
+SRC_URI="http://bitbucket.org/mmottl/postgresql-ocaml/downloads/${P}.tar.gz"
+HOMEPAGE="http://bitbucket.org/mmottl/postgresql-ocaml"
+IUSE="examples"
+
+DEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]
+ dev-db/postgresql-base
+ dev-db/postgresql-server"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}