summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-11-21 11:59:55 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-11-21 11:59:55 +0000
commit5895bfbf08713b46e298b17a9134db5c64514527 (patch)
tree7dcf4815c81dc56e08756d62c20f4a40fb71e431 /dev-ml/pgocaml
parentStable for x86, wrt bug #440318 (diff)
downloadgentoo-2-5895bfbf08713b46e298b17a9134db5c64514527.tar.gz
gentoo-2-5895bfbf08713b46e298b17a9134db5c64514527.tar.bz2
gentoo-2-5895bfbf08713b46e298b17a9134db5c64514527.zip
fix parallel build by Jeroen Roovers, bug #442798
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/pgocaml')
-rw-r--r--dev-ml/pgocaml/ChangeLog6
-rw-r--r--dev-ml/pgocaml/files/pgocaml-1.6-parallel-make.patch11
-rw-r--r--dev-ml/pgocaml/pgocaml-1.6.ebuild3
3 files changed, 18 insertions, 2 deletions
diff --git a/dev-ml/pgocaml/ChangeLog b/dev-ml/pgocaml/ChangeLog
index 10578b141fdd..9f621ae57837 100644
--- a/dev-ml/pgocaml/ChangeLog
+++ b/dev-ml/pgocaml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ml/pgocaml
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pgocaml/ChangeLog,v 1.1 2012/10/06 21:05:20 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pgocaml/ChangeLog,v 1.2 2012/11/21 11:59:55 aballier Exp $
+
+ 21 Nov 2012; Alexis Ballier <aballier@gentoo.org> pgocaml-1.6.ebuild,
+ +files/pgocaml-1.6-parallel-make.patch:
+ fix parallel build by Jeroen Roovers, bug #442798
*pgocaml-1.6 (07 Oct 2012)
diff --git a/dev-ml/pgocaml/files/pgocaml-1.6-parallel-make.patch b/dev-ml/pgocaml/files/pgocaml-1.6-parallel-make.patch
new file mode 100644
index 000000000000..daa0b167c230
--- /dev/null
+++ b/dev-ml/pgocaml/files/pgocaml-1.6-parallel-make.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -102,6 +102,8 @@
+ # Rules for core library.
+ #
+
++pa_pgsql.ml4: $(OBJS)
++
+ pa_pgsql.cmo: pa_pgsql.ml4
+ ocamlfind ocamlc $(OCAMLCFLAGS) $(OCAMLCPACKAGES) \
+ -pp "camlp4o pa_extend.cmo q_MLast.cmo $(P4_PARAMS) -impl" \
diff --git a/dev-ml/pgocaml/pgocaml-1.6.ebuild b/dev-ml/pgocaml/pgocaml-1.6.ebuild
index 7f7733471f8d..5f502939e081 100644
--- a/dev-ml/pgocaml/pgocaml-1.6.ebuild
+++ b/dev-ml/pgocaml/pgocaml-1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pgocaml/pgocaml-1.6.ebuild,v 1.1 2012/10/06 21:05:20 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pgocaml/pgocaml-1.6.ebuild,v 1.2 2012/11/21 11:59:55 aballier Exp $
EAPI=4
@@ -26,6 +26,7 @@ RDEPEND="${DEPEND}"
src_prepare() {
epatch "${FILESDIR}/${P}-test.patch"
epatch "${FILESDIR}/${P}-makefile.patch"
+ epatch "${FILESDIR}/${P}-parallel-make.patch"
}
src_configure() {