summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-02-05 18:06:58 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-02-05 18:06:58 +0000
commit4f4382f571ec3a7cca4918edd1c302e444398ce4 (patch)
treefa1ad6651f7141c980a9056fb88735b4b58f6feb /dev-ml/pcre-ocaml
parentStable for HPPA too. (diff)
downloadgentoo-2-4f4382f571ec3a7cca4918edd1c302e444398ce4.tar.gz
gentoo-2-4f4382f571ec3a7cca4918edd1c302e444398ce4.tar.bz2
gentoo-2-4f4382f571ec3a7cca4918edd1c302e444398ce4.zip
version bump, bug #208883
(Portage version: 2.1.4.1)
Diffstat (limited to 'dev-ml/pcre-ocaml')
-rw-r--r--dev-ml/pcre-ocaml/ChangeLog8
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-5.13.0.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-ml/pcre-ocaml/ChangeLog b/dev-ml/pcre-ocaml/ChangeLog
index 6b77457f37ee..adf99bae92ba 100644
--- a/dev-ml/pcre-ocaml/ChangeLog
+++ b/dev-ml/pcre-ocaml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/pcre-ocaml
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.15 2008/01/02 21:57:28 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.16 2008/02/05 18:06:58 aballier Exp $
+
+*pcre-ocaml-5.13.0 (05 Feb 2008)
+
+ 05 Feb 2008; Alexis Ballier <aballier@gentoo.org>
+ +pcre-ocaml-5.13.0.ebuild:
+ version bump, bug #208883
*pcre-ocaml-5.12.2 (02 Jan 2008)
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-5.13.0.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-5.13.0.ebuild
new file mode 100644
index 000000000000..603b81b133d2
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-5.13.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/pcre-ocaml-5.13.0.ebuild,v 1.1 2008/02/05 18:06:58 aballier Exp $
+
+inherit findlib eutils
+
+EAPI="1"
+
+DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
+HOMEPAGE="http://www.ocaml.info/home/ocaml_sources.html"
+SRC_URI="http://www.ocaml.info/ocaml_sources/${P}.tar.bz2"
+LICENSE="LGPL-2.1"
+
+DEPEND=">=dev-lang/ocaml-3.07
+ >=dev-libs/libpcre-4.5"
+SLOT="0"
+IUSE="examples +ocamlopt"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+pkg_setup() {
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
+src_compile() {
+ cd "${S}/lib"
+ emake byte-code-library || die "Failed to build byte code library"
+ if use ocamlopt; then
+ emake native-code-library || die "Failed to build native code library"
+ fi
+}
+
+src_install () {
+ export OCAMLFIND_INSTFLAGS="-optional"
+ findlib_src_install
+
+ # install documentation
+ dodoc README VERSION Changes
+
+ if use examples; then
+ for dir in examples/*
+ do
+ docinto $dir
+ dodoc $dir/*
+ done
+ fi
+}