summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-03-03 23:04:46 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-03-03 23:04:46 +0000
commit88f9f741069cc45a04438b527ceba802fe02c2f9 (patch)
tree7b5a931328aeecf5158e89bd964c4517dac4c2e3 /dev-ml/ocamlweb
parentspecify extension of the tex file so that latex doesnt try to compile the ELF... (diff)
downloadgentoo-2-88f9f741069cc45a04438b527ceba802fe02c2f9.tar.gz
gentoo-2-88f9f741069cc45a04438b527ceba802fe02c2f9.tar.bz2
gentoo-2-88f9f741069cc45a04438b527ceba802fe02c2f9.zip
dont prestrip files
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-ml/ocamlweb')
-rw-r--r--dev-ml/ocamlweb/ChangeLog6
-rw-r--r--dev-ml/ocamlweb/files/ocamlweb-1.37-strip.patch19
-rw-r--r--dev-ml/ocamlweb/ocamlweb-1.37.ebuild3
3 files changed, 26 insertions, 2 deletions
diff --git a/dev-ml/ocamlweb/ChangeLog b/dev-ml/ocamlweb/ChangeLog
index f17164d12e6b..49671037a5a2 100644
--- a/dev-ml/ocamlweb/ChangeLog
+++ b/dev-ml/ocamlweb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ml/ocamlweb
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlweb/ChangeLog,v 1.9 2008/03/03 23:00:02 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlweb/ChangeLog,v 1.10 2008/03/03 23:04:45 aballier Exp $
+
+ 03 Mar 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/ocamlweb-1.37-strip.patch, ocamlweb-1.37.ebuild:
+ dont prestrip files
03 Mar 2008; Alexis Ballier <aballier@gentoo.org>
+files/ocamlweb-1.37-tests.patch, ocamlweb-1.37.ebuild:
diff --git a/dev-ml/ocamlweb/files/ocamlweb-1.37-strip.patch b/dev-ml/ocamlweb/files/ocamlweb-1.37-strip.patch
new file mode 100644
index 000000000000..393391fe52ce
--- /dev/null
+++ b/dev-ml/ocamlweb/files/ocamlweb-1.37-strip.patch
@@ -0,0 +1,19 @@
+Index: ocamlweb-1.37/Makefile.in
+===================================================================
+--- ocamlweb-1.37.orig/Makefile.in
++++ ocamlweb-1.37/Makefile.in
+@@ -61,14 +61,12 @@ byte: ocamlweb.byte
+
+ ocamlweb: $(CAML_CMX) $(CAMLLEX_CMX) $(CMX)
+ $(CAMLCOPT) $(OPTFLAGS) -o $@ $(CAML_CMX) $(CAMLLEX_CMX) $(CMX)
+- strip ocamlweb
+
+ ocamlweb.byte: $(CAML_CMO) $(CAMLLEX_CMO) $(CMO)
+ $(CAMLC) $(BYTEFLAGS) -o $@ $(CAML_CMO) $(CAMLLEX_CMO) $(CMO)
+
+ ocamlweb.static: $(CAML_CMX) $(CAMLLEX_CMX) $(CMX)
+ $(CAMLCOPT) $(OPTFLAGS) -cclib -static -o $@ $(CAML_CMX) $(CAMLLEX_CMX) $(CMX)
+- strip $@
+
+ debug: $(CAML_CMO) $(CAMLLEX_CMO) $(CMO)
+ $(CAMLC) $(BYTEFLAGS) -o ocamlweb-debug $(CAML_CMO) $(CAMLLEX_CMO) $(CMO)
diff --git a/dev-ml/ocamlweb/ocamlweb-1.37.ebuild b/dev-ml/ocamlweb/ocamlweb-1.37.ebuild
index a9ae65f5ba12..37c42781f312 100644
--- a/dev-ml/ocamlweb/ocamlweb-1.37.ebuild
+++ b/dev-ml/ocamlweb/ocamlweb-1.37.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlweb/ocamlweb-1.37.ebuild,v 1.4 2008/03/03 23:00:02 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlweb/ocamlweb-1.37.ebuild,v 1.5 2008/03/03 23:04:45 aballier Exp $
inherit latex-package eutils
@@ -26,6 +26,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}/${P}-tests.patch"
+ epatch "${FILESDIR}/${P}-strip.patch"
}