summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-03-03 23:00:03 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-03-03 23:00:03 +0000
commit0db1985ad949776d3e7394c608969da25a06ae47 (patch)
tree20df24c2c66c9a8c73dccf6c98cb21270f823db5 /dev-ml/ocamlweb
parentVersion bump, DESCRIPTION improved, enabled voip for testing (don't expect gr... (diff)
downloadgentoo-2-0db1985ad949776d3e7394c608969da25a06ae47.tar.gz
gentoo-2-0db1985ad949776d3e7394c608969da25a06ae47.tar.bz2
gentoo-2-0db1985ad949776d3e7394c608969da25a06ae47.zip
specify extension of the tex file so that latex doesnt try to compile the ELF file during tests... inherit latex-package to have better TeX database handling in pkg phases
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-ml/ocamlweb')
-rw-r--r--dev-ml/ocamlweb/ChangeLog8
-rw-r--r--dev-ml/ocamlweb/files/ocamlweb-1.37-tests.patch15
-rw-r--r--dev-ml/ocamlweb/ocamlweb-1.37.ebuild26
3 files changed, 33 insertions, 16 deletions
diff --git a/dev-ml/ocamlweb/ChangeLog b/dev-ml/ocamlweb/ChangeLog
index 609147d84536..f17164d12e6b 100644
--- a/dev-ml/ocamlweb/ChangeLog
+++ b/dev-ml/ocamlweb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/ocamlweb
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlweb/ChangeLog,v 1.8 2008/03/03 22:51:14 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlweb/ChangeLog,v 1.9 2008/03/03 23:00:02 aballier Exp $
+
+ 03 Mar 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/ocamlweb-1.37-tests.patch, ocamlweb-1.37.ebuild:
+ specify extension of the tex file so that latex doesnt try to compile the
+ ELF file during tests... inherit latex-package to have better TeX database
+ handling in pkg phases
03 Mar 2008; Alexis Ballier <aballier@gentoo.org> ocamlweb-1.37.ebuild:
switch to latex-base
diff --git a/dev-ml/ocamlweb/files/ocamlweb-1.37-tests.patch b/dev-ml/ocamlweb/files/ocamlweb-1.37-tests.patch
new file mode 100644
index 000000000000..f148b1ffdb7d
--- /dev/null
+++ b/dev-ml/ocamlweb/files/ocamlweb-1.37-tests.patch
@@ -0,0 +1,15 @@
+Index: ocamlweb-1.37/Makefile.in
+===================================================================
+--- ocamlweb-1.37.orig/Makefile.in
++++ ocamlweb-1.37/Makefile.in
+@@ -130,8 +130,8 @@ BOOTSTRAP= bootstrap.tex output.mli outp
+
+ bootstrap: ocamlweb
+ ./ocamlweb -o test/ocamlweb.tex $(BOOTSTRAP)
+- cd test; $(LATEX) ocamlweb
+- cd test; grep -q "Rerun" ocamlweb.log && ($(LATEX) ocamlweb) || true
++ cd test; $(LATEX) ocamlweb.tex
++ cd test; grep -q "Rerun" ocamlweb.log && ($(LATEX) ocamlweb.tex) || true
+ - cd test; hevea -o ocamlweb.html ../ocamlweb.sty ocamlweb.tex
+ cd test; dvips ocamlweb.dvi -o ocamlweb.ps
+
diff --git a/dev-ml/ocamlweb/ocamlweb-1.37.ebuild b/dev-ml/ocamlweb/ocamlweb-1.37.ebuild
index 574946c79d20..a9ae65f5ba12 100644
--- a/dev-ml/ocamlweb/ocamlweb-1.37.ebuild
+++ b/dev-ml/ocamlweb/ocamlweb-1.37.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlweb/ocamlweb-1.37.ebuild,v 1.3 2008/03/03 22:51:14 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlweb/ocamlweb-1.37.ebuild,v 1.4 2008/03/03 23:00:02 aballier Exp $
+
+inherit latex-package eutils
DESCRIPTION="O'Caml literate programming tool"
HOMEPAGE="http://www.lri.fr/~filliatr/ocamlweb/"
@@ -19,6 +21,14 @@ DEPEND=">=dev-lang/ocaml-3.09
app-text/ptex
)"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-tests.patch"
+}
+
+
src_compile() {
econf || die
emake || die
@@ -28,17 +38,3 @@ src_install() {
emake UPDATETEX="" prefix="${D}/usr" MANDIR="${D}/usr/share/man" install || die
dodoc README CHANGES
}
-
-tex_regen() {
- einfo "Regenerating TeX database..."
- /usr/bin/mktexlsr /usr/share/texmf /var/spool/texmf > /dev/null
- eend $?
-}
-
-pkg_postinst() {
- tex_regen
-}
-
-pkg_postrm() {
- tex_regen
-}